summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-02-19 07:44:55 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-02-19 07:44:55 (GMT)
commit265782d3eb7ea6779562168b8714a8ab79ca30cd (patch)
tree62e9882b0e14602649cb208c01388fb2fc87f03b /configure.ac
parenta2b08b6e27b66cbe30778482ca63f22cc884db2d (diff)
downloadhdf5-265782d3eb7ea6779562168b8714a8ab79ca30cd.zip
hdf5-265782d3eb7ea6779562168b8714a8ab79ca30cd.tar.gz
hdf5-265782d3eb7ea6779562168b8714a8ab79ca30cd.tar.bz2
[svn-r26226] Fixed the --with-pthread option so that it correctly handles 'yes' and
'no', which was broken after other work in this area. Part of: HDFFV-9087 Tested on: 64-bit linux VM
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b4f747a..426ca2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1647,12 +1647,15 @@ if test "X$THREADSAFE" = "Xyes"; then
[withval=check])
case "$withval" in
- check)
+ check | yes)
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
if test "x$HAVE_PTHREAD" = "xyes"; then
AC_CHECK_LIB([pthread], [pthread_self],, [unset HAVE_PTHREAD])
fi
;;
+ no)
+ AC_MSG_ERROR([Must use Pthreads with thread safety])
+ ;;
*)
case "$withval" in
*,*)