summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-28 02:21:32 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-28 02:21:32 (GMT)
commit2845400b6d74c9ab48ea8d875f3873445aa55d38 (patch)
tree3072a136889611b0dc9f7ded207aa495ca0a76e7 /configure.ac
parent463be445edc24c25cf307ef5f7011a4ae5fcd557 (diff)
downloadhdf5-2845400b6d74c9ab48ea8d875f3873445aa55d38.zip
hdf5-2845400b6d74c9ab48ea8d875f3873445aa55d38.tar.gz
hdf5-2845400b6d74c9ab48ea8d875f3873445aa55d38.tar.bz2
[svn-r26639] Description:
Switch AC_TRY_RUN macros to AC_RUN_IFELSE macros. Tested on: MacOSX/64 10.10.2 (amazon) w/serial & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 23 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index fb1bbb9..8dd3a78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1409,18 +1409,18 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
AC_SUBST([LL_PATH]) LL_PATH="$LD_LIBRARY_PATH"
AC_CACHE_VAL([hdf5_cv_szlib_can_encode],
- [AC_TRY_RUN([
- #include <szlib.h>
-
- int main(void)
- {
+ [AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([
+ #include "szlib.h"
+ ],[[
/* SZ_encoder_enabled returns 1 if encoder is present */
- if(SZ_encoder_enabled() == 1)
- exit(0);
- else
- exit(1);
- }
- ], [hdf5_cv_szlib_can_encode=yes], [hdf5_cv_szlib_can_encode=no],)])
+ if(SZ_encoder_enabled() == 1)
+ exit(0);
+ else
+ exit(1);
+ ]])]
+ , [hdf5_cv_szlib_can_encode=yes], [hdf5_cv_szlib_can_encode=no],)]
+ )
AC_DEFINE([HAVE_FILTER_SZIP], [1],
[Define if support for szip filter is enabled])
@@ -1601,15 +1601,12 @@ if test "X$THREADSAFE" = "Xyes"; then
#include <pthread.h>
#endif
],[
- int main(void)
- {
pthread_attr_t attribute;
int ret;
pthread_attr_init(&attribute);
ret=pthread_attr_setscope(&attribute, PTHREAD_SCOPE_SYSTEM);
exit(ret==0 ? 0 : 1);
- }
])]
, [hdf5_cv_system_scope_threads=yes], [hdf5_cv_system_scope_threads=no], [hdf5_cv_system_scope_threads=no])])
@@ -1804,19 +1801,18 @@ AC_MSG_CHECKING([how to print long long])
AC_CACHE_VAL([hdf5_cv_printf_ll], [
for hdf5_cv_printf_ll in l ll L q unknown; do
- AC_TRY_RUN([
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-
- int main(void)
- {
- char *s = malloc(128);
- long long x = (long long)1048576 * (long long)1048576;
- sprintf(s,"%${hdf5_cv_printf_ll}d",x);
- exit(strcmp(s,"1099511627776"));
- }
- ], [break],,[continue])
+ AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ ],[[
+ char *s = malloc(128);
+ long long x = (long long)1048576 * (long long)1048576;
+ sprintf(s,"%${hdf5_cv_printf_ll}d",x);
+ exit(strcmp(s,"1099511627776"));
+ ]])]
+ , [break],,[continue])
done])
AC_MSG_RESULT([%${hdf5_cv_printf_ll}d and %${hdf5_cv_printf_ll}u])