summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJerome Soumagne <jsoumagne@hdfgroup.org>2015-03-11 20:15:25 (GMT)
committerJerome Soumagne <jsoumagne@hdfgroup.org>2015-03-11 20:15:25 (GMT)
commit9379314551566a44ea8ec6b3f64bcefa5eb43306 (patch)
tree380e5f4175e3cc8f135159f00afd88e35374766d /configure.ac
parent9eeb037725d5f0f162ef395747e601aeef03d759 (diff)
downloadhdf5-9379314551566a44ea8ec6b3f64bcefa5eb43306.zip
hdf5-9379314551566a44ea8ec6b3f64bcefa5eb43306.tar.gz
hdf5-9379314551566a44ea8ec6b3f64bcefa5eb43306.tar.bz2
[svn-r26435] Remove DEFAULT_LIBS from configure.ac and irix6.x config file which
was using it. Remove references to IRIX/irix* platform.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 3 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index cb9d698..33e4482 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,12 +132,6 @@ saved_user_FCFLAGS="$FCFLAGS"
saved_user_LDFLAGS="$LDFLAGS"
saved_user_CPPFLAGS="$CPPFLAGS"
-## Different compilers may need default libraries. They are specified in
-## the config/* files, so we put this statement here so that it'll be
-## set by the code which follows...
-##
-DEFAULT_LIBS=""
-
## Support F9X variable to define Fortran compiler if FC variable is
## not used. This should be deprecated in the future.
if test "x" = "x$FC"; then
@@ -251,12 +245,6 @@ case $host_os in
freebsd*)
host_os_novers=freebsd
;;
- irix5.*)
- host_os_novers=irix5.x
- ;;
- irix6.*)
- host_os_novers=irix6.x
- ;;
osf4.*)
host_os_novers=osf4.x
;;
@@ -938,7 +926,7 @@ case "$host" in
## many problems with including them.
AC_CHECK_HEADERS([sys/sysinfo.h sys/proc.h])
;;
- mips*-sgi*-irix*)
+ mips*-sgi*)
## The <sys/fpu.h> is needed on the SGI machines to turn off
## denormalized floating-point values going to zero. We do *not*
## attempt to locate these files on other systems because there
@@ -2502,9 +2490,7 @@ esac
## -----------------------------------------------------------------------
## Set flag to indicate that the machine can handle conversion from
## integers to long double. (This flag should be set "yes" for all
-## machines except all SGIs, where some conversions are
-## incorrect and its cache value is set "no" in its config/irix6.x and
-## irix5.x)
+## machines except all SGIs, where some conversions are incorrect)
##
AC_MSG_CHECKING([if accurately converting from integers to long double])
@@ -2575,8 +2561,7 @@ fi
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
## 'unsigned (long) long' values to 'float' and 'double' values.
-## (This flag should be set for all machines, except for the SGIs, where
-## the cache value is set in the config/irix6.x config file) and Solaris
+## (This flag should be set for all machines, except for the SGIs) and Solaris
## 64-bit machines, where the short program below tests if round-up is
## correctly handled.
##
@@ -3358,11 +3343,6 @@ fi
AC_SUBST([ROOT]) ROOT="`$pwd`"
## ----------------------------------------------------------------------
-## Move any compiler-specific libraries into the main LIBS varaible.
-##
-LIBS="$DEFAULT_LIBS $LIBS"
-
-## ----------------------------------------------------------------------
## Determine the runtime libraries we may need to include in the
## libtools command so that executables will find the correct dynamic
## libraries.