summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-01-29 14:15:48 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-01-29 14:15:48 (GMT)
commitaea0b5b46e8a017de05ce2bcc3983a38444f6b51 (patch)
tree78c433b2be0d0fc942a9ac1b1087029e18c1fbfb /configure.ac
parentfec3d82085dfe7fc5b36ee00389c642d5ec36d72 (diff)
downloadhdf5-aea0b5b46e8a017de05ce2bcc3983a38444f6b51.zip
hdf5-aea0b5b46e8a017de05ce2bcc3983a38444f6b51.tar.gz
hdf5-aea0b5b46e8a017de05ce2bcc3983a38444f6b51.tar.bz2
[svn-r26071] Moved setting H5_DEFAULT_VFD from configure to src/H5private.h.
Fixes HDFFV-9081 Tested on: jam
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index b45e9d1..10a6bb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2527,34 +2527,6 @@ if test -n "$PARALLEL"; then
fi
fi
-## --------------------------------------------------------------------------
-## Should the Default Virtual File Driver be compiled?
-##
-
-AC_MSG_CHECKING([for Default Virtual File Driver definition])
-AC_ARG_WITH([default-vfd],
- [AS_HELP_STRING([--with-default-vfd=driver],
- [Specify default file driver
- [default=sec2]])],,
- withval=sec2)
-
-if test "X$withval" = "Xsec2"; then
- AC_MSG_RESULT([yes])
- default_vfd=yes
- vfd_define=H5FD_SEC2
-elif test "X$withval" = "Xstdio"; then
- AC_MSG_RESULT([yes])
- default_vfd=yes
- vfd_define=H5FD_STDIO
-else
- AC_MSG_RESULT([no])
- default_vfd=no
-fi
-
-if test "X$default_vfd" = "Xyes"; then
- AC_DEFINE_UNQUOTED([DEFAULT_VFD], [$vfd_define],
- [Define the default virtual file driver to compile])
-fi
## ----------------------------------------------------------------------
## Check if Direct I/O driver is enabled by --enable-direct-vfd