summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-19 20:15:45 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-19 20:15:45 (GMT)
commitcac405283f0dd6e6aa528cd86303429ec9bb3fd2 (patch)
tree94bd20a27de0ae52da7cefd4f0106c97b1d6d0b4 /configure.ac
parentae9069e469ce3901ff6ac225afe3b1e35d88c6eb (diff)
downloadhdf5-cac405283f0dd6e6aa528cd86303429ec9bb3fd2.zip
hdf5-cac405283f0dd6e6aa528cd86303429ec9bb3fd2.tar.gz
hdf5-cac405283f0dd6e6aa528cd86303429ec9bb3fd2.tar.bz2
[svn-r26483] Description:
Remove INTEGER_TO_LDOUBLE_ACCURATE macro/define - we no longer support SGI systems. Tested on: Mac OSX/64 10.10.2 (amazon) w/serial & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 7495082..27ae96c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2442,27 +2442,6 @@ case "`uname`" in
;;
esac
-## -----------------------------------------------------------------------
-## Set flag to indicate that the machine can handle conversion from
-## integers to long double. (This flag should be set "yes" for all
-## machines except all SGIs, where some conversions are incorrect)
-##
-AC_MSG_CHECKING([if accurately converting from integers to long double])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_integer_to_ldouble_accurate=${hdf5_cv_integer_to_ldouble_accurate=no}
-else
- AC_CACHE_VAL([hdf5_cv_integer_to_ldouble_accurate], [hdf5_cv_integer_to_ldouble_accurate=yes])
-fi
-
-if test ${hdf5_cv_integer_to_ldouble_accurate} = "yes"; then
- AC_DEFINE([INTEGER_TO_LDOUBLE_ACCURATE], [1],
- [Define if your system can accurately convert from integers to long double values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
## 'unsigned long' to 'float' values.