summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-19 21:59:19 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-19 21:59:19 (GMT)
commitd63acf93b96364d65f10856c02aab7dc305e929a (patch)
treece46fc31b45bd3a2cead90f4fbbc803298030f6c /configure.ac
parentcea7454bef02d2c6656607703c122885c95c2fc6 (diff)
downloadhdf5-d63acf93b96364d65f10856c02aab7dc305e929a.zip
hdf5-d63acf93b96364d65f10856c02aab7dc305e929a.tar.gz
hdf5-d63acf93b96364d65f10856c02aab7dc305e929a.tar.bz2
[svn-r26492] Description:
Remove the FP_TO_ULLONG_ACCURATE and FP_TO_ULLONG_RIGHT_MAXIMUM macros/defines, which were added to address problems with older PGI compilers and HP-UX systems and are no longer supported. Tested on: MacOSX/64 10.10.2 (amazon) w/serial & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac81
1 files changed, 0 insertions, 81 deletions
diff --git a/configure.ac b/configure.ac
index 4933557..63cd4fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2444,87 +2444,6 @@ esac
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
-## 'float' or 'double' to 'unsigned long long' values.
-## (This flag should be set for all machines, except for PGI compiler
-## where round-up happens when the fraction of float-point value is greater
-## than 0.5.
-##
-AC_MSG_CHECKING([if accurately roundup converting floating-point to unsigned long long values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_ullong_accurate],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 111.60f;
- double d = 222.55L;
- unsigned long long l1 = (unsigned long long)f;
- unsigned long long l2 = (unsigned long long)d;
- int ret = 0;
-
- if(l1 == 112)
- ret = 1;
- if(l2 == 223)
- ret = 1;
-
-done:
- exit(ret);
- }
- ], [hdf5_cv_fp_to_ullong_accurate=yes], [hdf5_cv_fp_to_ullong_accurate=no],)])
-
-if test ${hdf5_cv_fp_to_ullong_accurate} = "yes"; then
- AC_DEFINE([FP_TO_ULLONG_ACCURATE], [1],
- [Define if your system roundup accurately converting floating-point to unsigned long long values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
-## 'float', 'double' or 'long double' to 'unsigned long long' values.
-## (This flag should be set for all machines, except for HP-UX machines
-## where the maximal number for unsigned long long is 0x7fffffffffffffff
-## during conversion.
-##
-AC_MSG_CHECKING([if right maximum converting floating-point to unsigned long long values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_ullong_right_maximum],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 9701917572145405952.00f;
- double d1 = 9701917572145405952.00L;
- long double d2 = 9701917572145405952.00L;
- double d3 = 2e40L;
- unsigned long long l1 = (unsigned long long)f;
- unsigned long long l2 = (unsigned long long)d1;
- unsigned long long l3 = (unsigned long long)d2;
- unsigned long long l4;
- unsigned long long l5 = 0x7fffffffffffffffULL;
- int ret = 0;
-
- if(l1 <= l5 || l2 <= l5 || l3 <= l5)
- ret = 1;
-
- l4 = (unsigned long long)d3;
- if(l4 <= l5)
- ret = 1;
-
-done:
- exit(ret);
- }
- ], [hdf5_cv_fp_to_ullong_right_maximum=yes], [hdf5_cv_fp_to_ullong_right_maximum=no],)])
-
-if test ${hdf5_cv_fp_to_ullong_right_maximum} = "yes"; then
- AC_DEFINE([FP_TO_ULLONG_RIGHT_MAXIMUM], [1],
- [Define if your system has right maximum convert floating-point to unsigned long long values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
## 'long double' to 'unsigned int' values. (This flag should be set for
## all machines, except for some Intel compilers on some Linux.)
##