summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2015-03-28 14:48:12 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2015-03-28 14:48:12 (GMT)
commited599421c5ef01347368d50b1b7dbed3b323c43f (patch)
tree2086a03a84db4e650dd6a4ca35c8548e63bbb8f6 /configure.ac
parent2845400b6d74c9ab48ea8d875f3873445aa55d38 (diff)
downloadhdf5-ed599421c5ef01347368d50b1b7dbed3b323c43f.zip
hdf5-ed599421c5ef01347368d50b1b7dbed3b323c43f.tar.gz
hdf5-ed599421c5ef01347368d50b1b7dbed3b323c43f.tar.bz2
[svn-r26641] configure.ac:
Remove VPATH and related search path syntax checking. Remove check for H5_LONE_COLON and checking for lone colon compiler confusion. tools/h5dump/testh5dumpxml.sh.in tools/h5dump/CMakeTestsXML.cmake Remove test skipping for compilers that were formerly confused by lone colon. Tested with h5committest.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac101
1 files changed, 0 insertions, 101 deletions
diff --git a/configure.ac b/configure.ac
index 8dd3a78..20aca8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -754,79 +754,6 @@ case "X-$RPATH" in
esac
## ----------------------------------------------------------------------
-## Sometimes makes think the `.PATH:' appearing before the first rule
-## with an action should override the `all' default target. So we have
-## to decide what the proper syntax is.
-##
-AC_MSG_CHECKING([how make searches directories])
-while true; do #for break
- ## The most common method is `VPATH=DIR1 DIR2 ...'
- cat >maketest <<EOF
-VPATH=$srcdir/config $srcdir/src $srcdir/bin
-.c.o:
- cp $< H5.o
-
-foo: H5.o
- rm -f H5.o
- @echo works
-EOF
-
- if (${MAKE-make} -f maketest foo) >/dev/null 2>&1; then
- SEARCH_RULE='VPATH='
- SEARCH_SEP=' '
- AC_MSG_RESULT([VPATH=DIR1 DIR2 ...])
- break
- fi
-
- ## The second most common method is like above except with the
- ## directories separated by colons.
- cat >maketest <<EOF
-VPATH=$srcdir/config:$srcdir/src:$srcdir/bin
-.c.o:
- cp $< H5.o
-
-foo: H5.o
- rm -f H5.o
- @echo works
-EOF
-
- if (${MAKE-make} -f maketest foo) >/dev/null 2>&1; then
- SEARCH_RULE='VPATH='
- SEARCH_SEP=':'
- AC_MSG_RESULT([VPATH=DIR1:DIR2:...])
- break
- fi
-
- ## pmake uses the construct `.PATH: DIR1 DIR2
- cat >maketest <<EOF
-.PATH: $srcdir/config $srcdir/src $srcdir/bin
-.c.o:
- cp $< H5.o
-
-foo: H5.o
- rm -f H5.o
- @echo works
-EOF
-
- if (MAKE= ${MAKE-make} -f maketest foo) >/dev/null 2>&1; then
- SEARCH_RULE='.PATH: '
- SEARCH_SEP=' '
- AC_MSG_RESULT([.PATH: DIR1 DIR2 ...])
- break
- fi
-
- ## No way for make to search directories
- SEARCH_RULE='## SEARCH DISABLED: '
- SEARCH_SEP=' '
- AC_MSG_RESULT([it doesn't])
- if test ! -f configure; then
- AC_MSG_ERROR([${MAKE-make} requires the build and source directories to be the same])
- fi
- break
-done
-rm maketest
-
-## ----------------------------------------------------------------------
## Production flags? Save the value in $CONFIG_MODE so we have it for
## the record.
##
@@ -1727,32 +1654,6 @@ AC_CHECK_FUNCS([snprintf srandom strdup symlink system])
AC_CHECK_FUNCS([tmpfile asprintf vasprintf vsnprintf waitpid])
## ----------------------------------------------------------------------
-## Check that a lone colon can be used as an argument
-## This is not true on Cray X1, which interprets a lone colon as a
-## system command.
-##
-AC_CACHE_CHECK([if lone colon can be used as an argument],
- [hdf5_cv_lone_colon],
- [
- echo "int main(int argc, char * argv[]) {return 0;}" > conftest.c
- $CC $CFLAGS conftest.c -o a.out> /dev/null 2> /dev/null
- echo "./a.out :" > conftest.sh
- chmod 700 conftest.sh
-
- ./conftest.sh 2> conftest.out
- rm -f a.out
- TEST_OUTPUT=`cat conftest.out`
-
- if test "X$TEST_OUTPUT" = "X"; then
- hdf5_cv_lone_colon=yes
- else
- hdf5_cv_lone_colon=no
- fi
- ])
-
-AC_SUBST([H5_LONE_COLON]) H5_LONE_COLON="$hdf5_cv_lone_colon"
-
-## ----------------------------------------------------------------------
## Check compiler characteristics
##
AC_C_CONST
@@ -2809,8 +2710,6 @@ AM_CONDITIONAL([BUILD_HDF5_HL_CONDITIONAL], [test "X$HDF5_HL" = "Xyes"])
## The directory search list
AC_SUBST([SEARCH]) SEARCH='$(srcdir) $(top_builddir)/src $(top_srcdir)/src'
-cmd='echo $SEARCH |sed "s/ /'$SEARCH_SEP'/g"'
-SEARCH="$SEARCH_RULE`eval $cmd`"
export SEARCH
## Some cleanup stuff