summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2017-06-29 14:23:35 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2017-06-29 14:23:35 (GMT)
commit598856b37e89195f1db1a2b9089782cd21d102f6 (patch)
tree73cab2f7a8dbb774af69192f17bb12dd2ffc05c0 /configure.ac
parent3da8951fb3fc3fa850558ba7ea4d44d507fc1664 (diff)
parent8c347d794a06b8b57c407499e1a441cc0f415380 (diff)
downloadhdf5-598856b37e89195f1db1a2b9089782cd21d102f6.zip
hdf5-598856b37e89195f1db1a2b9089782cd21d102f6.tar.gz
hdf5-598856b37e89195f1db1a2b9089782cd21d102f6.tar.bz2
Merge pull request #585 in HDFFV/hdf5 from ~DEROBINS/hdf5_der:configure_fortran_long_double_bug to develop
* commit '8c347d794a06b8b57c407499e1a441cc0f415380': Fixed a bug in autotools Fortran processing where a test for the presence of a C long double type always returned true.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4decf82..dd8d8b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -585,11 +585,11 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_STORAGE_SIZE], [1], [Define if we have Fortran intrinsic STORAGE_SIZE])
fi
- if test "X$HAVE_C_SIZEOF_FORTRAN" = "Xyes"; then
+ if test "X$HAVE_C_SIZEOF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_C_SIZEOF], [1], [Define if we have Fortran intrinsic C_SIZEOF])
fi
- if test "X$HAVE_SIZEOF_FORTRAN" = "Xyes"; then
+ if test "X$HAVE_SIZEOF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_SIZEOF], [1], [Define if we have Fortran intrinsic SIZEOF])
fi
@@ -604,7 +604,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
## Is C_LONG_DOUBLE different from C_DOUBLE
FORTRAN_C_LONG_DOUBLE_IS_UNIQUE="0"
- if test "X$FORTRAN_HAVE_C_LONG_DOUBLE"; then
+ if test "$FORTRAN_HAVE_C_LONG_DOUBLE" = "1"; then
PAC_PROG_FC_C_LONG_DOUBLE_EQ_C_DOUBLE
if test "X$C_LONG_DOUBLE_IS_UNIQUE_FORTRAN" = "Xyes"; then
FORTRAN_C_LONG_DOUBLE_IS_UNIQUE="1"