summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-19 22:12:58 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-19 22:12:58 (GMT)
commit54e68fe6894b1f3ce6f14f715f9375419e583ea9 (patch)
treeb1ec2580f3246f8f34ff6eba297ab7405a5ad581 /configure.ac
parentd63acf93b96364d65f10856c02aab7dc305e929a (diff)
downloadhdf5-54e68fe6894b1f3ce6f14f715f9375419e583ea9.zip
hdf5-54e68fe6894b1f3ce6f14f715f9375419e583ea9.tar.gz
hdf5-54e68fe6894b1f3ce6f14f715f9375419e583ea9.tar.bz2
[svn-r26494] Description:
Remove the LDOUBLE_TO_UINT_ACCURATE macro/define, it was addressing problems with older Intel compilers on Linux that are no longer supported. Tested on: MacOSX/64 10.10.2 (amazon) w/serial & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 63cd4fc..8e385bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2443,42 +2443,6 @@ case "`uname`" in
esac
## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
-## 'long double' to 'unsigned int' values. (This flag should be set for
-## all machines, except for some Intel compilers on some Linux.)
-##
-AC_MSG_CHECKING([if correctly converting long double to unsigned int values])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_ldouble_to_uint_accurate=${hdf5_cv_ldouble_to_uint_accurate=no}
-else
- AC_CACHE_VAL([hdf5_cv_ldouble_to_uint_accurate],
- [AC_TRY_RUN([
- int main(void)
- {
- long double ld = 2733248032.9183987530L;
- unsigned int i;
- int ret = 0;
-
- i = (unsigned int)ld;
- if(i!=2733248032 && i!=2733248031 && i!=2733248033)
- ret = 1;
-
- done:
- exit(ret);
- }
- ], [hdf5_cv_ldouble_to_uint_accurate=yes], [hdf5_cv_ldouble_to_uint_accurate=no],)])
-fi
-
-if test ${hdf5_cv_ldouble_to_uint_accurate} = "yes"; then
- AC_DEFINE([LDOUBLE_TO_UINT_ACCURATE], [1],
- [Define if your system can convert long double to unsigned int values correctly.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can _compile_
## 'unsigned long long' to 'float' and 'double' typecasts.
## (This flag should be set for all machines, except for under Windows when