summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-24 15:55:16 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-24 15:55:16 (GMT)
commitf793c50e4714166ddf02cce2380447d887356283 (patch)
treeef88dad2fda20ec6ee3b90c7303e55e52b8bc798 /configure.ac
parentc85497442b4a228b6d636d59fb5e51a932933142 (diff)
downloadhdf5-f793c50e4714166ddf02cce2380447d887356283.zip
hdf5-f793c50e4714166ddf02cce2380447d887356283.tar.gz
hdf5-f793c50e4714166ddf02cce2380447d887356283.tar.bz2
[svn-r25477] Added error if Fortran's default real is double precision. If it is and HL is being built then configure returns an error. This is due to HDFFV-889.
Tested: jam with intel and -r8 flag, both with and without --disable-hl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 32af3e7..115dfa8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -586,6 +586,8 @@ AM_CONDITIONAL([FORTRAN_HAVE_STORAGE_SIZE], [test "X$HAVE_STORAGE_SIZE" = "Xyes"
AM_CONDITIONAL([FORTRAN_2003_CONDITIONAL_F], [test "X$HAVE_FORTRAN_2003" = "Xyes"])
AM_CONDITIONAL([FORTRAN_DEFAULT_REALisDBLE_F], [test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"])
+
+
## ----------------------------------------------------------------------
## Check if they would like the C++ interface compiled
##
@@ -4153,10 +4155,17 @@ if test "X$HDF5_HL" = "Xyes"; then
HL="hl"
AC_DEFINE([INCLUDE_HL], [1],
[Define if HDF5's high-level library headers should be included in hdf5.h])
+
+## Check if Fortran's default real is double precision. If it is and HL is being built then configure
+## should fail due to bug HDFFV-889.
+ if test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"; then
+ AC_MSG_ERROR([Fortran high-level routines are not supported when the default REAL is DOUBLE PRECISION, use configure option --disable-hl.])
+ fi
else
echo "no"
fi
+
## ----------------------------------------------------------------------
## Some programs shouldn't be built by default (e.g., programs to generate
## data files used by tests, some optional tests).