summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-10-14 03:14:29 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-10-14 03:14:29 (GMT)
commit6d82d6c7cdb1c1449eb7783b3ecb7b50c0bc7949 (patch)
tree837aa41d177080aea953c42ff983e94977569bb3 /configure.ac
parentb40220174575adc12677ab9ab7ea46d533d2a041 (diff)
downloadhdf5-6d82d6c7cdb1c1449eb7783b3ecb7b50c0bc7949.zip
hdf5-6d82d6c7cdb1c1449eb7783b3ecb7b50c0bc7949.tar.gz
hdf5-6d82d6c7cdb1c1449eb7783b3ecb7b50c0bc7949.tar.bz2
[svn-r25701] Add LD path to HDF5 install directory to address HDFFV-8944.
Tested with h5committest and failed external daily tests.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 91c5b29..c17014b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,7 +115,11 @@ AM_CFLAGS="${AM_CFLAGS}"
AM_CXXFLAGS="${AM_CXXFLAGS}"
AM_FCFLAGS="${AM_FCFLAGS}"
AM_CPPFLAGS="${AM_CPPFLAGS}"
-AM_LDFLAGS="${AM_LDFLAGS}"
+if test "x$prefix" = xNONE; then
+ AM_LDFLAGS="${AM_LDFLAGS} -L$ac_default_prefix/lib"
+else
+ AM_LDFLAGS="$AM_LDFLAGS -L$prefix/lib"
+fi
CFLAGS="${CFLAGS}"
CXXFLAGS="${CXXFLAGS}"
FCFLAGS="${FCFLAGS}"
@@ -1904,7 +1908,7 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
if test -z "$LD_LIBRARY_PATH"; then
export LD_LIBRARY_PATH="$szlib_lib"
else
- export LD_LIBRARY_PATH="$szlib_lib:$LD_LIBRARY_PATH"
+ export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$szlib_lib"
fi
AC_SUBST([LL_PATH]) LL_PATH="$LD_LIBRARY_PATH"