summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-01-27 20:16:07 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-01-27 20:16:07 (GMT)
commitd29c5a6e6ad8cb50a94e9215d2b2b8682e56818f (patch)
tree1a6dc47a0890a4dd8bcc3a87575b1ba82f22d42f /configure.ac
parent4d34a0c6ad62e0482b699987c6852014dc60b699 (diff)
downloadhdf5-d29c5a6e6ad8cb50a94e9215d2b2b8682e56818f.zip
hdf5-d29c5a6e6ad8cb50a94e9215d2b2b8682e56818f.tar.gz
hdf5-d29c5a6e6ad8cb50a94e9215d2b2b8682e56818f.tar.bz2
[svn-r26052] Fixed false positive tests for intrensic functions.
Tested: jam (mpi, gfortran, intel) --enable-fortran, and --enable-fortran --enable-fortran2003
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 393b194..cd4fa9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,7 +399,11 @@ if test "X$HDF_FORTRAN2003" = "Xyes" && test "X$HDF_FORTRAN" = "Xno"; then
echo "no"
AC_MSG_ERROR([--enable-fortran must be used with --enable-fortran2003])
else
- echo "yes"
+ if test "X$HDF_FORTRAN2003" = "Xyes" && test "X$HDF_FORTRAN" = "Xyes"; then
+ echo "yes"
+ else
+ echo "no"
+ fi
fi
HAVE_SIZEOF="no"
@@ -446,11 +450,6 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_PROG_FC([PAC_FC_SEARCH_LIST],)
AC_F9X_MODS
- ## It seems that libtool (as of Libtool 1.5.14) is trying to
- ## configure itself for Fortran 77.
- ## Tell it that our F77 compiler is $FC (actually a F9X compiler)
- F77=$FC
-
## Change to the Fortran 90 language
AC_LANG_PUSH(Fortran)