summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-01-30 08:08:57 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-01-30 08:08:57 (GMT)
commitec45cabfc767b4ae29e654a207d64948aaf1b394 (patch)
tree710cc56ead5bd04f3e1599992b8666976f2645e1 /configure.ac
parent37d1800ec0e2774e3cdcb46ebb3392caf4f4a3e3 (diff)
downloadhdf5-ec45cabfc767b4ae29e654a207d64948aaf1b394.zip
hdf5-ec45cabfc767b4ae29e654a207d64948aaf1b394.tar.gz
hdf5-ec45cabfc767b4ae29e654a207d64948aaf1b394.tar.bz2
[svn-r26083] Changed the default for building the direct VFD to 'no'.
Updated the direct VFD help string to make it more clear where it is suported. Part of HDFFV-7566 and HDFFV-7567 Tested on: jam (configure only)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8dc0790..3a14090 100644
--- a/configure.ac
+++ b/configure.ac
@@ -540,7 +540,7 @@ AC_SUBST(HL_FOR) HL_FOR=""
AC_MSG_CHECKING([if high level library is enabled])
AC_ARG_ENABLE([hl],
[AS_HELP_STRING([--enable-hl],
- [Enable the high level library [default=yes]])],
+ [Enable the high-level library [default=yes]])],
[HDF5_HL=$enableval],
[HDF5_HL=yes])
@@ -2521,13 +2521,15 @@ fi
## Check if Direct I/O driver is enabled by --enable-direct-vfd
##
-AC_MSG_CHECKING([for Direct Virtual File Driver support])
+AC_MSG_CHECKING([for direct virtual file driver (VFD) support])
AC_ARG_ENABLE([direct-vfd],
[AS_HELP_STRING([--enable-direct-vfd],
- [Build the Direct I/O Virtual File Driver
- [default=yes]])],
- [DIRECT_VFD=$enableval], [DIRECT_VFD=yes])
+ [Build the direct I/O virtual file driver (VFD).
+ This is based on the POSIX (sec2) VFD and
+ requires the open() call to take the O_DIRECT
+ flag. [default=no]])],
+ [DIRECT_VFD=$enableval], [DIRECT_VFD=no])
if test "$DIRECT_VFD" = "yes"; then
AC_CACHE_VAL([hdf5_cv_direct_io],
@@ -2548,7 +2550,7 @@ if test "$DIRECT_VFD" = "yes"; then
if test ${hdf5_cv_direct_io} = "yes"; then
AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_DIRECT], [1],
- [Define if the direct I/O virtual file driver should be compiled])
+ [Define if the direct I/O virtual file driver (VFD) should be compiled])
else
AC_MSG_RESULT([no])
DIRECT_VFD=no