summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-22 21:03:56 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-22 21:03:56 (GMT)
commit6301d5a6cb7527f7f2eed0d60d1faaf154ed9976 (patch)
tree176b7d6a14e240faed2d823a7751cf1890ac66a8 /configure.ac
parent97ac37592b75b1f799f9b24a71ced0fa85925086 (diff)
downloadhdf5-6301d5a6cb7527f7f2eed0d60d1faaf154ed9976.zip
hdf5-6301d5a6cb7527f7f2eed0d60d1faaf154ed9976.tar.gz
hdf5-6301d5a6cb7527f7f2eed0d60d1faaf154ed9976.tar.bz2
Fix for shared fortran libraries on mac (HDFFV-2772).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d8e9b9e..b6f37bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3482,10 +3482,11 @@ chmod 755 tools/src/misc/h5cc
if test "X$HDF_FORTRAN" = "Xyes"; then
chmod 755 fortran/src/h5fc
- ## tell libtool to pass the correct argument linker, needed only for intel compiler.
+ ## tell libtool to pass the correct argument linker, needed only for intel compiler. This script
+ ## replaces the 3rd occurance, which is for Fortran, of wl="" with wl="-Wl,"
case "`uname`" in
Darwin*)
- cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv libtool.tmp libtool && chmod 755 libtool
+ cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool
;;
esac
fi