summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-22 20:45:17 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-22 20:45:17 (GMT)
commit97ac37592b75b1f799f9b24a71ced0fa85925086 (patch)
treee721390db5265cde5e273bad10e5c55cde5e9671 /configure.ac
parent2b2a1d605e0f556fcdf38345420047b5776c7ba2 (diff)
downloadhdf5-97ac37592b75b1f799f9b24a71ced0fa85925086.zip
hdf5-97ac37592b75b1f799f9b24a71ced0fa85925086.tar.gz
hdf5-97ac37592b75b1f799f9b24a71ced0fa85925086.tar.bz2
Fix for shared fortran libraries on mac (HDFFV-2772).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 458a3d2..d8e9b9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3482,6 +3482,12 @@ chmod 755 tools/src/misc/h5cc
if test "X$HDF_FORTRAN" = "Xyes"; then
chmod 755 fortran/src/h5fc
+ ## tell libtool to pass the correct argument linker, needed only for intel compiler.
+ case "`uname`" in
+ Darwin*)
+ cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv libtool.tmp libtool && chmod 755 libtool
+ ;;
+ esac
fi
if test "X$HDF_CXX" = "Xyes"; then