summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2020-07-06 21:09:49 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2020-07-07 00:22:26 (GMT)
commitd9105b2fcf04f36ea348bf9726a49c05cacc0b78 (patch)
tree4edeae919315a2b137c7adce880a297944b0f58d /configure.ac
parentd52b27ad1d8142945a92310b79ab79171e76a3c3 (diff)
downloadhdf5-d9105b2fcf04f36ea348bf9726a49c05cacc0b78.zip
hdf5-d9105b2fcf04f36ea348bf9726a49c05cacc0b78.tar.gz
hdf5-d9105b2fcf04f36ea348bf9726a49c05cacc0b78.tar.bz2
Fixes Autotools builds on Solaris after monotonic timer changes
clock_gettime() wasn't being found, so some configure changes were needed to set an appropriate POSIX level and use a C99 compiler. This required several compiler flag changes. Autotools only
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7e3cb5..e16cbba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1249,6 +1249,13 @@ case "$host_cpu-$host_vendor-$host_os" in
## VFD on Linux systems.
H5_CPPFLAGS="-D_GNU_SOURCE $H5_CPPFLAGS"
;;
+
+ *solaris*)
+ ## Solaris also needs _POSIX_C_SOURCE set correctly to pick up
+ ## clock_gettime().
+ H5_CPPFLAGS="-D_POSIX_C_SOURCE=200112L $H5_CPPFLAGS"
+ H5_CPPFLAGS="-D_GNU_SOURCE $H5_CPPFLAGS"
+ ;;
esac
## Need to add the AM_ and H5_ into CFLAGS/CPPFLAGS to make them visible