summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-24 22:06:27 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-24 22:06:27 (GMT)
commit460b629e0384bd8780e0a47407d4b33a8e02b1f4 (patch)
tree56ecf3d4cbb8f8bb0ee75a1afcb8e4951797f062 /configure.ac
parent92b1916151c9162141f153136117b03730882873 (diff)
downloadhdf5-460b629e0384bd8780e0a47407d4b33a8e02b1f4.zip
hdf5-460b629e0384bd8780e0a47407d4b33a8e02b1f4.tar.gz
hdf5-460b629e0384bd8780e0a47407d4b33a8e02b1f4.tar.bz2
[svn-r26560] Description:
Bring r26483 from autotools_rework branch back to trunk: Remove INTEGER_TO_LDOUBLE_ACCURATE macro/define - we no longer support SGI systems. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (daily tested on branch for >1 week)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 68927a0..04122e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2574,27 +2574,6 @@ case "`uname`" in
;;
esac
-## -----------------------------------------------------------------------
-## Set flag to indicate that the machine can handle conversion from
-## integers to long double. (This flag should be set "yes" for all
-## machines except all SGIs, where some conversions are incorrect)
-##
-AC_MSG_CHECKING([if accurately converting from integers to long double])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_integer_to_ldouble_accurate=${hdf5_cv_integer_to_ldouble_accurate=no}
-else
- AC_CACHE_VAL([hdf5_cv_integer_to_ldouble_accurate], [hdf5_cv_integer_to_ldouble_accurate=yes])
-fi
-
-if test ${hdf5_cv_integer_to_ldouble_accurate} = "yes"; then
- AC_DEFINE([INTEGER_TO_LDOUBLE_ACCURATE], [1],
- [Define if your system can accurately convert from integers to long double values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
## 'unsigned long' to 'float' values.