summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2013-04-24 18:27:04 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2013-04-24 18:27:04 (GMT)
commit357424423c6771ad3caee2c61e90b4745080d432 (patch)
treed59c3aed9d980046abb9458dfdbf0e3e14953d00 /configure.ac
parented5a2bc1c1b8b4d81a3eaeedb7d523d3365dc32a (diff)
downloadhdf5-357424423c6771ad3caee2c61e90b4745080d432.zip
hdf5-357424423c6771ad3caee2c61e90b4745080d432.tar.gz
hdf5-357424423c6771ad3caee2c61e90b4745080d432.tar.bz2
[svn-r23618] Bug fix: HDFFV-8390
Threadsafe works in v1.8.10 release. But it fails v1.8.11-pre1 tarball in configure stage now. There was a typo in the configure around the checking of pthread library. Fixed it. Tested: AIX and also h5committested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b313e0..6a1ab73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1945,7 +1945,7 @@ AC_ARG_WITH([pthread],
case "$withval" in
yes)
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
AC_CHECK_LIB([pthread], [pthread_self],, [unset HAVE_PTHREAD])
fi
;;
@@ -1987,7 +1987,7 @@ case "$withval" in
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
fi
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
if test -n "$pthread_lib"; then
saved_LDFLAGS="$LDFLAGS"
saved_AM_LDFLAGS="$AM_LDFLAGS"