summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJerome Soumagne <jsoumagne@hdfgroup.org>2015-10-20 06:28:17 (GMT)
committerJerome Soumagne <jsoumagne@hdfgroup.org>2015-10-20 06:28:17 (GMT)
commit2094d8646199996f655bb5f56f142216bc2abfcf (patch)
tree2af40c4dddb881f62de5d61643e94932821ae29d /configure.ac
parent2af0d74216f1cdb0608a535a74c2a318a60b6e26 (diff)
downloadhdf5-2094d8646199996f655bb5f56f142216bc2abfcf.zip
hdf5-2094d8646199996f655bb5f56f142216bc2abfcf.tar.gz
hdf5-2094d8646199996f655bb5f56f142216bc2abfcf.tar.bz2
[svn-r28138] Add first support for _Bool and make hbool_t a "real" _Bool if available
Fix tests accordingly and fix misuse of hbool_t in various places Fix initialization of H5Pgcpl/ocpl structs in property decoding routines Tested on: Linux/32 (jam) Linux/64 (platypus) Linux/PPC64 (ostrich) MacOSX/64 10.11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18601f1..6ab2eb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -951,6 +951,7 @@ AC_CHECK_HEADERS([sys/socket.h sys/types.h])
AC_CHECK_HEADERS([stddef.h setjmp.h features.h])
AC_CHECK_HEADERS([dirent.h])
AC_CHECK_HEADERS([stdint.h], [C9x=yes])
+AC_CHECK_HEADERS([stdbool.h])
## Darwin
AC_CHECK_HEADERS([mach/mach_time.h])
@@ -1130,6 +1131,17 @@ EOF
AC_CHECK_SIZEOF([off_t], [4])
AC_CHECK_SIZEOF([off64_t], [8])
+if test "X$C9x" = "Xyes"; then
+ cat >>confdefs.h <<\EOF
+#ifdef HAVE_STDBOOL_H
+#include <stdbool.h> /* for bool definition */
+#else
+#define bool _Bool
+#endif
+EOF
+AC_CHECK_SIZEOF([bool], [1])
+fi
+
## Checkpoint the cache
AC_CACHE_SAVE