summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-20 21:46:56 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-20 21:46:56 (GMT)
commit4f18b095d8cdd5c75cabe76f68c452984523c5f6 (patch)
treef2436e1fecd5e8ee651885a9fb685bb419909c83 /configure.ac
parent57393bc0483fe164d3c44129ff786e1333406ce2 (diff)
downloadhdf5-4f18b095d8cdd5c75cabe76f68c452984523c5f6.zip
hdf5-4f18b095d8cdd5c75cabe76f68c452984523c5f6.tar.gz
hdf5-4f18b095d8cdd5c75cabe76f68c452984523c5f6.tar.bz2
[svn-r26511] Description:
Remove the FP_TO_INTEGER_OVERFLOW_WORKS macro/define, which is for working around bugs in the Cray X1 compiler and is no longer supported. Tested on: MacOSX/64 10.10.2 (amazon) w/serial & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 0074907..4da0dfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2409,37 +2409,6 @@ case "`uname`" in
esac
## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can handle overflow converting
-## all floating-point to all integer types.
-## (This flag should be set for all machines, except for Cray X1 where
-## floating exception is generated when the floating-point value is greater
-## than the maximal integer value).
-##
-AC_MSG_CHECKING([if overflows normally converting floating-point to integer values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_integer_overflow_works],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 2147483648.0f;
- int i;
-
- i = (int)f;
-
-done:
- exit(0);
- }
- ], [hdf5_cv_fp_to_integer_overflow_works=yes], [hdf5_cv_fp_to_integer_overflow_works=no],)])
-
-if test ${hdf5_cv_fp_to_integer_overflow_works} = "yes"; then
- AC_DEFINE([FP_TO_INTEGER_OVERFLOW_WORKS], [1],
- [Define if your system can handle overflow converting floating-point to integer values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
## Set the flag to indicate that the machine is using a special algorithm to convert
## 'long double' to '(unsigned) long' values. (This flag should only be set for
## the IBM Power6 Linux. When the bit sequence of long double is