summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-10-19 21:58:33 (GMT)
committerGitHub <noreply@github.com>2023-10-19 21:58:33 (GMT)
commit5844f498b03c9da5eb99c6665f4a8ff4663b190f (patch)
treed1f0e2d676ff06300a1de769c2afcc929f734484 /configure.ac
parent5672fd817732e6a7fda3886010452bc7c8598cf8 (diff)
downloadhdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.zip
hdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.tar.gz
hdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.tar.bz2
Add an option to disable doxygen warn as error (#3708)
Add for both CMake and the Autotools * HDF5_ENABLE_DOXY_WARNINGS: ON/OFF (Default: ON) * --enable-doxygen-errors: enable/disable (Default: enable) The default will fail compile if the doxygen parsing generates warnings. The option can be disabled if certain versions of doxygen have parsing issues. i.e. 1.9.5, 1.9.8. Fixes #3398
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 02c47d6..44ab43a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,6 +1207,30 @@ AC_ARG_ENABLE([doxygen],
AC_MSG_RESULT([$HDF5_DOXYGEN])
+## Check if they would like to enable doxygen warnings as errors
+##
+
+## This needs to be exposed for the library info file.
+AC_SUBST([HDF5_DOXY_WARNINGS])
+
+## Default is to consider doxygen warnings as errors
+DOXY_ERR=yes
+
+AC_MSG_CHECKING([if doxygen warnings as errors is enabled])
+
+AC_ARG_ENABLE([doxygen-errors],
+ [AS_HELP_STRING([--enable-doxygen-errors],
+ [Error on HDF5 doxygen warnings [default=yes]])],
+ [DOXY_ERR=$enableval])
+
+if test "X$DOXY_ERR" = "Xyes"; then
+ HDF5_DOXY_WARNINGS="FAIL_ON_WARNINGS"
+else
+ HDF5_DOXY_WARNINGS="NO"
+
+fi
+AC_MSG_RESULT([$HDF5_DOXY_WARNINGS])
+
if test "X$HDF5_DOXYGEN" = "Xyes"; then
DX_DOXYGEN_FEATURE(ON)
DX_DOT_FEATURE(OFF)
@@ -1269,6 +1293,7 @@ if test "X$HDF5_DOXYGEN" = "Xyes"; then
DOXYGEN_STRIP_FROM_PATH='$(SRCDIR)'
DOXYGEN_STRIP_FROM_INC_PATH='$(SRCDIR)'
DOXYGEN_PREDEFINED='H5_HAVE_DIRECT H5_HAVE_LIBHDFS H5_HAVE_MAP_API H5_HAVE_PARALLEL H5_HAVE_ROS3_VFD H5_DOXYGEN H5_HAVE_SUBFILING_VFD H5_HAVE_IOC_VFD H5_HAVE_MIRROR_VFD'
+ DOXYGEN_WARN_AS_ERROR=${HDF5_DOXY_WARNINGS}
DX_INIT_DOXYGEN([HDF5], [./doxygen/Doxyfile], [hdf5lib_docs])
fi