summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-06-29 04:58:38 (GMT)
committerGitHub <noreply@github.com>2021-06-29 04:58:38 (GMT)
commit734d317da9c759799c92ff47e05e3be7e3e969a9 (patch)
treef928e0c17e91b9a1124ee9e4b0217a1b4fe68b17 /configure.ac
parent5ddfbc2a736f7f4cc8b109ee3f3e53c4655dbec1 (diff)
downloadhdf5-734d317da9c759799c92ff47e05e3be7e3e969a9.zip
hdf5-734d317da9c759799c92ff47e05e3be7e3e969a9.tar.gz
hdf5-734d317da9c759799c92ff47e05e3be7e3e969a9.tar.bz2
Removes obsolete equivalents of C99's __func__ (#800)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d9a6a5e..dbeb968 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2024,18 +2024,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]],[[int __attribute__((unused)) x]])],
AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])])
-AC_MSG_CHECKING([for __func__ extension])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]],[[ const char *fname = __func__; ]])],
- [AC_DEFINE([HAVE_C99_FUNC], [1],
- [Define if the compiler understands the __func__ keyword])
- AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])])
-AC_MSG_CHECKING([for __FUNCTION__ extension])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]],,[[ const char *fname = __FUNCTION__; ]])],
- [AC_DEFINE([HAVE_FUNCTION], [1],
- [Define if the compiler understands the __FUNCTION__ keyword])
- AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])])
AC_MSG_CHECKING([for C99 designated initialization support])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
typedef struct {