summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-09-15 13:33:49 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-09-15 13:33:49 (GMT)
commitef8c73ecc3e0a42885f8a6cde6a27d521658c1e2 (patch)
tree9eee832db2498c6bc1fafe3c71cfe91b15e8eaf0 /configure.ac
parent1177e649253e39aa5c8f76cb3374e412c542e415 (diff)
downloadhdf5-ef8c73ecc3e0a42885f8a6cde6a27d521658c1e2.zip
hdf5-ef8c73ecc3e0a42885f8a6cde6a27d521658c1e2.tar.gz
hdf5-ef8c73ecc3e0a42885f8a6cde6a27d521658c1e2.tar.bz2
[svn-r27789] Merge of r27683-r27698 from the trunk.
Tested on: h5committest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 58d31a8..d188529 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1464,8 +1464,7 @@ AC_CACHE_SAVE
AC_MSG_CHECKING([for thread safe support])
AC_ARG_ENABLE([threadsafe],
[AS_HELP_STRING([--enable-threadsafe],
- [Enable thread-safe capability. This will disable the high-level library.
- You can override this behavior by specifying --enable-hl and --enable-unsupported.
+ [Enable thread-safe capability. Not compatible with the high-level library, Fortran, or C++ wrappers.
[default=no]])],
[THREADSAFE=$enableval])
@@ -1480,7 +1479,7 @@ AC_ARG_ENABLE([threadsafe],
## users will have to add --disable-hl to the configure options.
if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
if test "X${HDF5_HL}" = "Xyes" -a "X${enable_threadsafe}" = "Xyes"; then
- AC_MSG_ERROR([The thread-safe library is incompatible with the high-level library. --enable-unsupported will allow building the high-level library, though this configuration is not supported by The HDF Group. Alternatively,--disable-hl can be used to prevent building the high-level library (recommended).])
+ AC_MSG_ERROR([The thread-safe library is incompatible with the high-level library. --disable-hl can be used to prevent building the high-level library (recommended). Alternatively, --enable-unsupported will allow building the high-level library, though this configuration is not supported by The HDF Group.])
fi
fi