summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2013-03-21 04:04:19 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2013-03-21 04:04:19 (GMT)
commita0ec9c282b3dbabec9d1f46e86c37336b9cd490b (patch)
treef4cad7f3c83a1312763130cf6205d18947cc8238 /configure.ac
parente8955b876cc81e9cd7318418435d5cd861854c2a (diff)
downloadhdf5-a0ec9c282b3dbabec9d1f46e86c37336b9cd490b.zip
hdf5-a0ec9c282b3dbabec9d1f46e86c37336b9cd490b.tar.gz
hdf5-a0ec9c282b3dbabec9d1f46e86c37336b9cd490b.tar.bz2
[svn-r23410] HDFFV-8264: Using F2003, build fails on Fedora with undefined reference to __h5r_MOD_h5rget_region_region_f
This turned out being an issue with configure. The reporter submitted a patch which fixed the fact that we should not be setting AM_FCFLAGS (an automake variable) with FFLAGS (a user variable). I removed this, and we now only set FFLAGS if the environment variable is set, otherwise we don't. Tested: jam (gnu)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 38b342a..a57d149 100644
--- a/configure.ac
+++ b/configure.ac
@@ -434,9 +434,10 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
## --------------------------------------------------------------------
## General Fortran flags
- ##
- AM_FCFLAGS="${AM_FCFLAGS} ${FFLAGS}"
- FCFLAGS="${FCFLAGS} ${FFLAGS}"
+ ## Only add FFLAGS to FCFLAGS if it's set.
+ if test "x$FFLAGS" != "x" ; then
+ FCFLAGS="${FCFLAGS} ${FFLAGS}"
+ fi
## --------------------------------------------------------------------
## Fortran source extention