summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Lu <songyulu@hdfgroup.org>2019-01-08 23:59:03 (GMT)
committerRay Lu <songyulu@hdfgroup.org>2019-01-08 23:59:03 (GMT)
commit44a67451be8dfc4f7b2bede29f2b8bf865ac1787 (patch)
tree10bcf864079217940454c2abff7371bd58c349ba /configure.ac
parentd3b107d1a42c26b2b94dc498b8f3ba0940bc60e4 (diff)
parentb02de315b93ac29d2483a91d526b110a25073505 (diff)
downloadhdf5-44a67451be8dfc4f7b2bede29f2b8bf865ac1787.zip
hdf5-44a67451be8dfc4f7b2bede29f2b8bf865ac1787.tar.gz
hdf5-44a67451be8dfc4f7b2bede29f2b8bf865ac1787.tar.bz2
Merge pull request #1450 in HDFFV/hdf5 from ~SONGYULU/hdf5_ray:TRILAB-98-dt_arith-and-cpp_testhdf5-tests to develop
* commit 'b02de315b93ac29d2483a91d526b110a25073505': NNSA Tri-LabsTRILAB-98: Another two test cases out. NNSA Tri-Labs TRILAB-98: Taking out a few more test cases. NNSA Tri-Labs TRILAB-98 dt_arith and cpp_testhdf5 tests fail on sierra.llnl.gov: According to the group decision, simply provide a macro to disable some failing test cases on sierra (IBM power9 cpu). All failing cases involve long double data type.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b12e57..25c4b78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2969,6 +2969,30 @@ else
fi
## ----------------------------------------------------------------------
+## Set the flag to indicate that the machine is IBM ppc64le and cannot
+## accurately convert some long double values.
+##
+AC_MSG_CHECKING([if the system is IBM ppc64le and cannot correctly convert some long double values])
+
+TEST_SRC="`(echo \"#define H5_DISABLE_SOME_LDOUBLE_CONV_TEST 1\"; cat $srcdir/config/cmake/ConversionTests.c)`"
+
+if test ${ac_cv_sizeof_long_double} = 0; then
+ hdf5_cv_disable_some_ldouble_conv=${hdf5_cv_disable_some_ldouble_conv=no}
+else
+ AC_CACHE_VAL([hdf5_cv_disable_some_ldouble_conv],
+ [AC_RUN_IFELSE([AC_LANG_SOURCE([$TEST_SRC])],
+ [hdf5_cv_disable_some_ldouble_conv=yes], [hdf5_cv_disable_some_ldouble_conv=no],[])])
+fi
+
+if test ${hdf5_cv_disable_some_ldouble_conv} = "yes"; then
+ AC_DEFINE([DISABLE_SOME_LDOUBLE_CONV], [1],
+ [Define if your system is IBM ppc64le and cannot convert some long double values correctly.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+## ----------------------------------------------------------------------
## Set some variables for general configuration information to be saved
## and installed with the libraries (used to generate libhdf5.settings).
##