summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSongyu Lu <songyulu@hdfgroup.org>2019-01-08 02:28:37 (GMT)
committerSongyu Lu <songyulu@hdfgroup.org>2019-01-08 02:28:37 (GMT)
commit75c105a2a442b9a0cd42d7aa1e95da55ae8e4804 (patch)
tree717122a86f3eb3aa679de88d25447dd0ce663b11 /configure.ac
parent7bf6d847ae36940f1b1147820356795c7764dbeb (diff)
downloadhdf5-75c105a2a442b9a0cd42d7aa1e95da55ae8e4804.zip
hdf5-75c105a2a442b9a0cd42d7aa1e95da55ae8e4804.tar.gz
hdf5-75c105a2a442b9a0cd42d7aa1e95da55ae8e4804.tar.bz2
NNSA Tri-Labs TRILAB-98 dt_arith and cpp_testhdf5 tests fail on sierra.llnl.gov: According to the group decision, simply provide a macro to disable some failing test cases on sierra (IBM power9 cpu). All failing cases involve long double data type.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 21ad68b..f8e538a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2960,6 +2960,30 @@ else
fi
## ----------------------------------------------------------------------
+## Set the flag to indicate that the machine is power9 and cannot
+## accurately convert some long double values.
+##
+AC_MSG_CHECKING([if the system is power9 and cannot correctly convert some long double values])
+
+TEST_SRC="`(echo \"#define H5_DISABLE_SOME_LDOUBLE_CONV_TEST 1\"; cat $srcdir/config/cmake/ConversionTests.c)`"
+
+if test ${ac_cv_sizeof_long_double} = 0; then
+ hdf5_cv_disable_some_ldouble_conv=${hdf5_cv_disable_some_ldouble_conv=no}
+else
+ AC_CACHE_VAL([hdf5_cv_disable_some_ldouble_conv],
+ [AC_RUN_IFELSE([AC_LANG_SOURCE([$TEST_SRC])],
+ [hdf5_cv_disable_some_ldouble_conv=yes], [hdf5_cv_disable_some_ldouble_conv=no],[])])
+fi
+
+if test ${hdf5_cv_disable_some_ldouble_conv} = "yes"; then
+ AC_DEFINE([DISABLE_SOME_LDOUBLE_CONV], [1],
+ [Define if your system is power9 and cannot convert some long double values correctly.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+## ----------------------------------------------------------------------
## Set some variables for general configuration information to be saved
## and installed with the libraries (used to generate libhdf5.settings).
##