summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2018-06-15 18:53:36 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2018-06-15 18:53:36 (GMT)
commit87829e06189cd9b29583b5ca8065b52b1f4cd523 (patch)
tree495ea989045018667409ee2e9a9d1ffded52091f /configure.ac
parent413bc90ec95524c72d0576bc9f1fc5356e541473 (diff)
parent57f64b92d19fed2879ee9bafe1d29bfac865d54c (diff)
downloadhdf5-87829e06189cd9b29583b5ca8065b52b1f4cd523.zip
hdf5-87829e06189cd9b29583b5ca8065b52b1f4cd523.tar.gz
hdf5-87829e06189cd9b29583b5ca8065b52b1f4cd523.tar.bz2
Merge pull request #1111 in HDFFV/hdf5 from hdf5_1_10.sync to hdf5_1_10
* commit '57f64b92d19fed2879ee9bafe1d29bfac865d54c': (30 commits) HDFFV-10405: Using h5fget_obj_count_f with a file id of H5F_OBJ_ALL_F does not work properly HDFFV-10405: Using h5fget_obj_count_f with a file id of H5F_OBJ_ALL_F does not work properly HDFFV-10405: Using h5fget_obj_count_f with a file id of H5F_OBJ_ALL_F does not work properly Cleaned up H5Fmount/unmount code. Normalization with vol_integration branch. Add fortran MPI to test and example Add mpi include folders for fortran C objects Normalization with the vol_integration branch. Fixed MANIFEST Fix usage of compression lib in shared tests Fix jni function call version Fix the error found after earlier checkin. H5O_info fixes for java and examples Added a RELASE.txt entry for HDFFV-10505. Changed 'deprecated' to indicate 'no longer supported' in the --enable-debug/production configure flags. (1) Made the change according to the pull request feedback. (2) Removed the performance test form test/th5o.c: will decide on what needs to be done to show speedup via HDFFV-10463. Normalize with vol_integration. Removed unused H5MF functions and updated FUNC_ENTER macros and naming in H5MFsection.c. Restored some unused #defines to the deprecated section of H5Dpublic.h. Changes made based on feedback from pull request #1039. ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d17d2d1..5b9e6e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1954,12 +1954,12 @@ AC_DEFINE_UNQUOTED([PRINTF_LL_WIDTH], ["$hdf5_cv_printf_ll"],
## around to help people migrate to 1.10.x and newer versions.
##
AC_ARG_ENABLE([debug],
- [AS_HELP_STRING([--enable-debug], [DEPRECATED: use --enable-build-mode=debug])],
- [AC_MSG_ERROR([--enable-debug is deprecated, use --enable-build-mode=debug instead.])])
+ [AS_HELP_STRING([--enable-debug], [OPTION CHANGE: use --enable-build-mode=debug])],
+ [AC_MSG_ERROR([--enable-debug is no longer supported, use --enable-build-mode=debug instead.])])
AC_ARG_ENABLE([production],
- [AS_HELP_STRING([--enable-production], [DEPRECATED: use --enable-build-mode=production])],
- [AC_MSG_ERROR([--enable-production is deprecated, use --enable-build-mode=production instead.])])
+ [AS_HELP_STRING([--enable-production], [OPTION CHANGE: use --enable-build-mode=production])],
+ [AC_MSG_ERROR([--enable-production is no longer supported, use --enable-build-mode=production instead.])])
## ----------------------------------------------------------------------