summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-07-27 17:29:22 (GMT)
committerGitHub <noreply@github.com>2022-07-27 17:29:22 (GMT)
commitfc9f31ad8c8ff4122e8bb2997e0a2bfa89cb054b (patch)
tree8c8c33c722ed8aefd3a738a77a03972249880cea /configure.ac
parenta0a1959c58973095194f2d9ac5f9b13bb7b14fb4 (diff)
downloadhdf5-fc9f31ad8c8ff4122e8bb2997e0a2bfa89cb054b.zip
hdf5-fc9f31ad8c8ff4122e8bb2997e0a2bfa89cb054b.tar.gz
hdf5-fc9f31ad8c8ff4122e8bb2997e0a2bfa89cb054b.tar.bz2
fortran module folder from GH#1411 #1922 (#1942)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e3d8971..4837a73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,8 @@ AM_JNIFLAGS="${AM_JNIFLAGS}"
AM_JAVACFLAGS="${AM_JAVACFLAGS}"
AM_JAVAFLAGS="${AM_JAVAFLAGS}"
AM_LDFLAGS="${AM_LDFLAGS}"
+
+## Flags passed in by the user
CFLAGS="${CFLAGS}"
CXXFLAGS="${CXXFLAGS}"
FCFLAGS="${FCFLAGS}"
@@ -615,6 +617,13 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_PROG_FC([PAC_FC_SEARCH_LIST],)
AC_F9X_MODS
+ ## Allow setting the fortran module install dir
+ AC_ARG_WITH([fmoddir],
+ [AS_HELP_STRING([--with-fmoddir=DIR], [Fortran module install directory])],
+ [fmoddir=$withval],
+ [fmoddir="\${includedir}"])
+ AC_SUBST([fmoddir], [$fmoddir])
+
## Change to the Fortran 90 language
AC_LANG_PUSH(Fortran)