summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-12-20 11:03:16 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-12-20 11:03:16 (GMT)
commitfe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec (patch)
treea482951f2d94a0f3d4e85b65791f73c0493874af /configure.ac
parent34c0328c4d44a26916ebe0756ad5d74ac3c1dec8 (diff)
downloadhdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.zip
hdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.tar.gz
hdf5-fe1a5b4279bbbf705c6d3b3886ffe2a963bd07ec.tar.bz2
Added a shell script so we can run the parallel flush test
on OpenMPI.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a1370f..3416705 100644
--- a/configure.ac
+++ b/configure.ac
@@ -841,9 +841,13 @@ fi
## command). The value of this variable is
## substituted in *.in files.
##
+## RUNPARALLELSCRIPT -- Identical to RUNPARALLEL but without
+## the special makefile protection for environment
+## variables.
AC_SUBST([PARALLEL])
AC_SUBST([RUNSERIAL])
AC_SUBST([RUNPARALLEL])
+AC_SUBST([RUNPARALLELSCRIPT])
AC_SUBST([TESTPARALLEL])
## ----------------------------------------------------------------------
@@ -2511,9 +2515,10 @@ case "X-$enable_parallel" in
PAC_PROG_FC_MPI_CHECK
fi
- ## Set RUNPARALLEL to mpiexec if not set yet.
+ ## Set RUNPARALLEL and RUNPARALLELSCRIPT to mpiexec if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
RUNPARALLEL="mpiexec -n \$\${NPROCS:=6}"
+ RUNPARALLELSCRIPT="mpiexec -n ${NPROCS:=6}"
fi
;;
@@ -3444,6 +3449,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
test/test_filter_plugin.sh
test/test_usecases.sh
testpar/Makefile
+ testpar/testpflush.sh
tools/Makefile
tools/lib/Makefile
tools/src/Makefile