summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2024-01-29 19:13:33 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2024-02-14 21:32:01 (GMT)
commit30b0f89f869c947cce41dbdb983533400f607604 (patch)
tree50e930c644f08585e074693bc8b6429a603c682b /configure.ac
parent56d9be146fb27456e4c517e49ccf920396824d71 (diff)
downloadhdf5-30b0f89f869c947cce41dbdb983533400f607604.zip
hdf5-30b0f89f869c947cce41dbdb983533400f607604.tar.gz
hdf5-30b0f89f869c947cce41dbdb983533400f607604.tar.bz2
Add API support for Fortran MPI_F08 module definitions. (#3959)
* revert to using c-stub for _F08 MPI APIs * use mpi compiler wrappers for cmake and nvhpc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5a635b..44dc430 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2840,6 +2840,25 @@ if test -n "$PARALLEL"; then
AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])]
)
+
+ AC_LANG_PUSH([Fortran])
+ AC_MSG_CHECKING([for MPI-3 module mpi_f08])
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([],
+ [
+ USE mpi_f08
+ IMPLICIT NONE
+ TYPE(MPI_Comm) :: comm
+ TYPE(MPI_INFO) :: info
+ ]
+ )
+ ],
+ [AC_DEFINE([HAVE_MPI_F08], [1],
+ [Define if mpi_f08 module exist])
+ AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])]
+ )
+ AC_LANG_POP(Fortran)
fi
## ----------------------------------------------------------------------