summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-04-22 06:25:12 (GMT)
committerGitHub <noreply@github.com>2023-04-22 06:25:12 (GMT)
commit7707859279a60b32d2b6c915442a7c04d44445b4 (patch)
tree890d16aa2408b270368b36ea4f05ca20fe2f16f6 /configure.ac
parenta4371b6fce577852691dfdeac642dec1dd4b9453 (diff)
downloadhdf5-7707859279a60b32d2b6c915442a7c04d44445b4.zip
hdf5-7707859279a60b32d2b6c915442a7c04d44445b4.tar.gz
hdf5-7707859279a60b32d2b6c915442a7c04d44445b4.tar.bz2
Merge with develop (#2790)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b1d10c..1cc487a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3747,11 +3747,13 @@ esac
AC_SUBST([DEFAULT_API_VERSION])
AC_MSG_CHECKING([which version of public symbols to use by default])
AC_ARG_WITH([default-api-version],
- [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110|v112|v114)],
+ [AS_HELP_STRING([--with-default-api-version=(default|v16|v18|v110|v112|v114)],
[Specify default release version of public symbols
[default=v114]])],,
[withval=v114])
+## Allowing "default" allows the GitHub CI to check that we didn't forget
+## to change the defaults when creating a new major version
if test "X$withval" = "Xv16"; then
AC_MSG_RESULT([v16])
DEFAULT_API_VERSION=v16
@@ -3772,7 +3774,7 @@ elif test "X$withval" = "Xv112"; then
DEFAULT_API_VERSION=v112
AC_DEFINE([USE_112_API_DEFAULT], [1],
[Define using v1.12 public API symbols by default])
-elif test "X$withval" = "Xv114"; then
+elif test "X$withval" = "Xv114" -o "X$withval" = "Xdefault"; then
AC_MSG_RESULT([v114])
DEFAULT_API_VERSION=v114
AC_DEFINE([USE_114_API_DEFAULT], [1],