summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2016-05-12 18:36:32 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2016-05-12 18:36:32 (GMT)
commit92806fb5e6778373638c29d36ef3e4c1c1ac3ab0 (patch)
treeb0e1e1b02aa33f6f86dab15939dc5b07215d02be /configure.ac
parent9494f92ae29c6fbe9286f0b8efaeefe38c4115bf (diff)
downloadhdf5-92806fb5e6778373638c29d36ef3e4c1c1ac3ab0.zip
hdf5-92806fb5e6778373638c29d36ef3e4c1c1ac3ab0.tar.gz
hdf5-92806fb5e6778373638c29d36ef3e4c1c1ac3ab0.tar.bz2
[svn-r29922] merged -c29913 from 1.10.0 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e552366..94e508b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -617,10 +617,9 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
FORTRAN_SIZEOF_LONG_DOUBLE=${ac_cv_sizeof_long_double}
AC_DEFINE_UNQUOTED([FORTRAN_SIZEOF_LONG_DOUBLE], ["${ac_cv_sizeof_long_double}"], [Determine the size of C long double])
-
dnl get the largest sizeof for REAL kinds
- max_real_fortran_sizeof="`echo $PAC_FC_ALL_REAL_KINDS_SIZEOF | sed -ne 's/.*,\([[0-9]]*\)\}/\1/p'`"
- max_real_fortran_kind="`echo \"[$]PAC_FC_ALL_REAL_KINDS\" | sed -ne 's/.*,\([[0-9]]*\)\}/\1/p'`"
+ max_real_fortran_sizeof="`echo $PAC_FC_ALL_REAL_KINDS_SIZEOF | sed -ne 's/.*,\([[0-9]]*\)}/\1/p'`"
+ max_real_fortran_kind="`echo $PAC_FC_ALL_REAL_KINDS | sed -ne 's/.*,\([[0-9]]*\)}/\1/p'`"
dnl remove the invalid kind from the list
if test "$ac_cv_sizeof___float128" != 0;then
@@ -636,6 +635,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
])
PAC_FC_ALL_REAL_KINDS="`echo $PAC_FC_ALL_REAL_KINDS | sed -e 's/,[[0-9]]\+}/}/g'`"
PAC_FC_ALL_REAL_KINDS_SIZEOF="`echo $PAC_FC_ALL_REAL_KINDS_SIZEOF | sed -e 's/,[[0-9]]\+}/}/g'`"
+
fi
fi
AC_MSG_CHECKING([for Fortran interoperable KINDS with C])