summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-12-17 03:54:20 (GMT)
committerGitHub <noreply@github.com>2022-12-17 03:54:20 (GMT)
commita2ce031f32114fdb8d785f5f9685dc5633e73467 (patch)
tree74ffa5706bcfef93723ce25c1418ac2289f1cfa6 /configure.ac
parent7379c6cad9c41be3ba6a82cc31a73779cb33168f (diff)
downloadhdf5-a2ce031f32114fdb8d785f5f9685dc5633e73467.zip
hdf5-a2ce031f32114fdb8d785f5f9685dc5633e73467.tar.gz
hdf5-a2ce031f32114fdb8d785f5f9685dc5633e73467.tar.bz2
1.14 Disable hl tools by default #2313 (#2318)
* Disable hl tools by default #2313 * Only gif tools are deprecated * Update autotools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf55006..2a377f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -833,6 +833,7 @@ AC_LANG_POP(C++)
## library is disabled.
AC_SUBST([HDF5_HL])
AC_SUBST([HDF5_HL_TOOLS])
+AC_SUBST([HDF5_HL_GIF_TOOLS])
## The high-level library and high-level tools are enabled unless the build mode
## is clean.
@@ -888,6 +889,21 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING([if the high-level GIF tools are enabled])
+AC_ARG_ENABLE([hltools],
+ [AS_HELP_STRING([--enable-hlgiftools],
+ [Enable the high-level GIF tools.
+ [default=no]
+ ])],
+ [HDF5_HL_GIF_TOOLS=$enableval])
+
+if test "X${HDF5_GIF_HL}" = "Xyes" -a "X-$HDF5_HL_TOOLS" = "X-yes" -a "X-$HDF5_HL_GIF_TOOLS" = "X-yes"; then
+ AC_MSG_RESULT([yes])
+ HL_GIF_TOOLS="tools"
+else
+ AC_MSG_RESULT([no])
+fi
+
## ----------------------------------------------------------------------
## Enable new references for dimension scales
@@ -3907,6 +3923,7 @@ AM_CONDITIONAL([BUILD_TESTS_CONDITIONAL], [test "X$HDF5_TESTS" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_PARALLEL_CONDITIONAL], [test -n "$TESTPARALLEL"])
AM_CONDITIONAL([BUILD_TOOLS_CONDITIONAL], [test "X$HDF5_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_TOOLS_HL_CONDITIONAL], [test "X$HDF5_HL_TOOLS" = "Xyes"])
+AM_CONDITIONAL([BUILD_TOOLS_HL_GIF_CONDITIONAL], [test "X$HDF5_HL_GIF_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_DOXYGEN_CONDITIONAL], [test "X$HDF5_DOXYGEN" = "Xyes"])
## ----------------------------------------------------------------------