summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-02-17 01:09:04 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-02-17 01:09:04 (GMT)
commitad0925c214c9d3afe9a013aa1e3adfb2bc3ba4dc (patch)
treeb09eecd7d0c54fea92af1eadce26a052bcaf2262 /configure.ac
parent6731dca11fb634e0eec285c59d61fe0de79f042d (diff)
downloadhdf5-ad0925c214c9d3afe9a013aa1e3adfb2bc3ba4dc.zip
hdf5-ad0925c214c9d3afe9a013aa1e3adfb2bc3ba4dc.tar.gz
hdf5-ad0925c214c9d3afe9a013aa1e3adfb2bc3ba4dc.tar.bz2
[svn-r29129] Added NO_SYMBOLS_CFLAGS, etc. to allow stripping symbols when
--disable-symbols is specified and to ensure that production mode (where symbol stripping is usually a part of the FLAGS) doesn't conflict with --enable-symbols. This will allow better (though still limited) debugging of production/optimized code. The PGI, XLC, Intel, and Solaris files were not modified and do not generate the symbol removal flag at this time. They'll be updated in future check-ins. In the meantime, production mode on those platforms still usually strips symbols. This check-in also updates the Cygwin-specific files to use the new autotools FLAGS and option scheme when uncommon (non-gnu, etc.) Fortran compilers are used. Tested on: 64-bit Ubuntu 15.10 (Linux 4.2.0 x86_64) gcc 5.2.1 autotools serial (prod/debug w/ and w/o symbols) symbol presence/absence checked with objdump
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17e9ff9..ed6c3b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1913,6 +1913,9 @@ case "X-$SYMBOLS" in
AC_MSG_RESULT([yes])
;;
X-no)
+ H5_CFLAGS="$H5_CFLAGS $NO_SYMBOLS_CFLAGS"
+ H5_CXXFLAGS="$H5_CXXFLAGS $NO_SYMBOLS_CXXFLAGS"
+ H5_FCFLAGS="$H5_FCFLAGS $NO_SYMBOLS_FCFLAGS"
AC_MSG_RESULT([no])
;;
*)