summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-06-06 19:36:44 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2020-06-06 19:36:44 (GMT)
commitde9491e3651350969b2a75c602984a3786656dcb (patch)
treee05eeec195ede16a5c41b9db9974561fb57b4206 /configure.ac
parentf7bc306c19a3bd8f9a31a78d81a7bb5160bbbaf8 (diff)
downloadhdf5-de9491e3651350969b2a75c602984a3786656dcb.zip
hdf5-de9491e3651350969b2a75c602984a3786656dcb.tar.gz
hdf5-de9491e3651350969b2a75c602984a3786656dcb.tar.bz2
Add flags from config/clang-warnings/*general files to H5 C and CXX flags for all versions of Clang and Clang++ compilers.
Switched from cut to awk in testcheck_version.sh.in to avoid dependence on tab vs. " " in version definitions in H5public.h.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 14 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 50f823e..cf1e463 100644
--- a/configure.ac
+++ b/configure.ac
@@ -311,16 +311,8 @@ fi
if test "X$CC_BASENAME" = "Xclang"; then
AC_SUBST([CLANG_SANITIZE_CHECKS])
- ## These are all the packages that use H5*_DEBUG.
- ## There is no harm in specifying a package not in this list;
- ## you'll just get an unused H5<pkg>_DEBUG symbol.
- ##
- ## Some packages that define debug checks or output are
- ## too specialized or have huge performance hits. These
- ## are not listed in the "all" packages list.
- ##
- ##all_packages="Address"
-
+ # There are several sanitizer tools. At present we are testing
+ # and describing only -fsanitizer=address with autotools.
case "X-$CLANG_SANITIZE_CHECKS" in
X-no|X-none)
CLANG_SANITIZE_CHECKS=none
@@ -332,8 +324,18 @@ if test "X$CC_BASENAME" = "Xclang"; then
esac
AC_MSG_RESULT([$CLANG_SANITIZE_CHECKS])
- ## Define H5*_DEBUG symbols that control package output
- ## NOTE: No sanity checking done here!
+ # Other tools can be added to the list of checks
+ # The clang compiler doesn't support some of them; they should be
+ # checked before adding them to the list in the help message.
+ # The sanitizers/sanitizers.cmake file lists these options:
+ # address, memory, memoryWithOrigins, undefined, thread, leak,
+ # 'address;undefined'. Which and which combinations of these are
+ # supported varies by compiler version, but unsupported options
+ # or combinations will result in configure errors reported in config.log.
+ # Comma separated lists of sanitize options wil be entered intact in
+ # one -fsanitize=<list> flag. Space separated lists will be entered in
+ # separate -fsanitize=<item> flags.
+ # NOTE: No sanity checking done here!
if test -n "$CLANG_SANITIZE_LIST"; then
H5_CFLAGS="$H5_CFLAGS -fno-omit-frame-pointer"
for sanitizer in `echo $CLANG_SANITIZE_LIST`; do