summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2006-04-15 23:50:15 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2006-04-15 23:50:15 (GMT)
commit014e9630d2e59301c7c15b8be4ec7914ba7bf524 (patch)
treecbb2ff40fecf9119b280ae39fde68224c6752526 /configure.in
parent0aa70b37480c16ca0eb306de31fd17848acc6e05 (diff)
downloadhdf5-014e9630d2e59301c7c15b8be4ec7914ba7bf524.zip
hdf5-014e9630d2e59301c7c15b8be4ec7914ba7bf524.tar.gz
hdf5-014e9630d2e59301c7c15b8be4ec7914ba7bf524.tar.bz2
[svn-r12260] Purpose:
Changed to production mode default on, debug mode default off to prepare for 1.8.0alpha0 release. Platforms tested: Tested in heping but only did the configure and compared the output with previous default output. The changes were pretty simple.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f14dbd9..a4555d2 100644
--- a/configure.in
+++ b/configure.in
@@ -754,7 +754,7 @@ AC_ARG_ENABLE(production,
[Determines how to run the compiler.])])
case "X-$enable_production" in
- X-yes)
+ X-|X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
@@ -796,7 +796,7 @@ case "X-$enable_production" in
CXXFLAGS="$CXXFLAGS $PROD_CXXFLAGS"
FCFLAGS="$FCFLAGS $PROD_FCFLAGS"
;;
- X-|X-no)
+ X-no)
enable_production="no"
AC_MSG_RESULT([development])
CONFIG_MODE=development
@@ -1747,7 +1747,7 @@ AC_ARG_ENABLE([debug],
AC_SUBST([DEBUG_PKG])
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-|X-yes)
+ X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT([default ($DEBUG_PKG)])
@@ -1757,7 +1757,7 @@ case "X-$DEBUG_PKG" in
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT([all ($DEBUG_PKG)])
;;
- X-no|X-none)
+ X-|X-no|X-none)
AC_MSG_RESULT([none])
DEBUG_PKG=
CPPFLAGS="$CPPFLAGS -DNDEBUG"