summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-05-01 01:21:28 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-05-01 01:21:28 (GMT)
commit0917096d34762b93f13203bec928f9dd124e7bfa (patch)
tree9cd8ad194d2d60717cef2aa4f03509181edde176 /configure.in
parentcb0c04e1d4d3a5be3b3b07bb81ab647a3adccd43 (diff)
downloadhdf5-0917096d34762b93f13203bec928f9dd124e7bfa.zip
hdf5-0917096d34762b93f13203bec928f9dd124e7bfa.tar.gz
hdf5-0917096d34762b93f13203bec928f9dd124e7bfa.tar.bz2
[svn-r16902] Description:
Bring r16875:16901 from trunk to revise_chunks branch. Tested on: FreebSD/32 6.3 (duty) (h5committest not required for this branch)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 070f9ee..aee6bba 100644
--- a/configure.in
+++ b/configure.in
@@ -2468,6 +2468,19 @@ case "X-$enable_parallel" in
fi
dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
+ dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
+ dnl Find the path where aprun is located.
+ for path in `echo $PATH | ${TR} ":" " "`; do
+ if test -x $path/aprun; then
+ RUNPARALLEL="aprun -q -n \$\${NPROCS:=3}"
+ break;
+ fi
+ done
+ fi
+
+ dnl Set RUNPARALLEL to mpirun if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
fi