summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-28 22:13:46 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-28 22:13:46 (GMT)
commit40c79d0602c1b736093d5b245e6aeac8db1ef01b (patch)
tree69b39d478f67eb29d9a50c12cd07f79b8bb4df16 /configure.in
parentcd25a7690abbd3665996dc7657b13101ba032c79 (diff)
downloadhdf5-40c79d0602c1b736093d5b245e6aeac8db1ef01b.zip
hdf5-40c79d0602c1b736093d5b245e6aeac8db1ef01b.tar.gz
hdf5-40c79d0602c1b736093d5b245e6aeac8db1ef01b.tar.bz2
[svn-r12172] Purpose:
configure refactoring Description: Migrated a couple of Fortran macros to standard autoconf macros Solution: HDF5 had a couple of macros, AC_TRY_FLINK and AC_CHECK_FLIB, which were adaptions of standard autoconf macros before those macros supported F90. Now Autoconf seems to have better support for f90, so its standard macros AC_TRY_LINK and AC_CHECK_LIB can do this job (and move the burden of supporting those macros to autoconf). Platforms tested: heping, modi4, copper
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index decdeb2..3f31a2e 100644
--- a/configure.in
+++ b/configure.in
@@ -2160,10 +2160,11 @@ case "X-$enable_parallel" in
AC_LANG_PUSH(Fortran)
dnl Try link a simple MPI program. If fail, try again with -lmpi.
- AC_TRY_FLINK(mpif.h, [
+ AC_TRY_LINK(, [
+ include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],,
- AC_CHECK_FLIB(mpi, [
+ AC_CHECK_LIB(mpi, [
include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],, PARALLEL=no))
@@ -2171,10 +2172,11 @@ case "X-$enable_parallel" in
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.
if test "X$PARALLEL" = "Xyes"; then
- AC_TRY_FLINK(mpif.h, [
+ AC_TRY_LINK(, [
+ include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],,
- AC_CHECK_FLIB(mpio, [
+ AC_CHECK_LIB(mpio, [
include 'mpif.h'
integer:: ierr
call mpi_file_open( ierr )],, PARALLEL=no))