summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-09-29 04:57:44 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-09-29 04:57:44 (GMT)
commit412fbdfad3dffee714ac19e7beba3135dd33427a (patch)
treedff761b5c8082cbc9877e7fa7be81e40dca5b906 /configure.in
parent6baed67905135dcb3f86b5472a36c7c201e93921 (diff)
downloadhdf5-412fbdfad3dffee714ac19e7beba3135dd33427a.zip
hdf5-412fbdfad3dffee714ac19e7beba3135dd33427a.tar.gz
hdf5-412fbdfad3dffee714ac19e7beba3135dd33427a.tar.bz2
[svn-r11476] Purpose:
feature. Description: added the recognition of -lmpich as a form of MPI library. Platforms tested: Tested in heping. Real test will be in MCR.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2e366e9..4af6591 100644
--- a/configure.in
+++ b/configure.in
@@ -2152,8 +2152,11 @@ case "X-$enable_parallel" in
AC_MSG_RESULT([provided by compiler])
PARALLEL=yes
- dnl Try link a simple MPI program. If fail, try again with -lmpi.
- AC_TRY_LINK(, MPI_Init(),, AC_CHECK_LIB(mpi, MPI_Init,, PARALLEL=no))
+ dnl Try link a simple MPI program. If fail, try again with -lmpi and
+ dnl -lmpich.
+ AC_TRY_LINK(, MPI_Init(),, \
+ AC_CHECK_LIB(mpi, MPI_Init,, \
+ AC_CHECK_LIB(mpich, MPI_Init,, PARALLEL=no)))
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.