summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2006-03-22 18:44:55 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2006-03-22 18:44:55 (GMT)
commit4b703ef698a5242c9cd4d3181b28d8f0acb5e786 (patch)
tree44548fd60e9455d73435b6da72048bb4929dc474 /configure.in
parentff67dcf8ba859882297d11d455dca71fdab40043 (diff)
downloadhdf5-4b703ef698a5242c9cd4d3181b28d8f0acb5e786.zip
hdf5-4b703ef698a5242c9cd4d3181b28d8f0acb5e786.tar.gz
hdf5-4b703ef698a5242c9cd4d3181b28d8f0acb5e786.tar.bz2
[svn-r12130] Purpose:
Disable debugging feature Description: Disable the "function stack" by default & take out it's dependency on the "enable-debug" configure flag. The function stack code can slow things down quite a bit and shouldn't be enabled for the upcoming alpha testing. Platforms tested: FreeBSD 4.11 (sleipnir) Linux 2.4 (chicago) Mac OSX (amazon)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 4 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index f600b51..decdeb2 100644
--- a/configure.in
+++ b/configure.in
@@ -1822,26 +1822,18 @@ dnl
AC_MSG_CHECKING([whether function stack tracking is enabled])
AC_ARG_ENABLE([funcstack],
[AC_HELP_STRING([--enable-funcstack],
- [Enable the function stack tracing.
- Default=no if debug is disabled.])],
+ [Enable the function stack tracing (for developer debugging).])],
[FUNCSTACK=$enableval])
-dnl Default to no if debug is disabled
-if test "X-$FUNCSTACK" = X- ; then
- if test -z "$DEBUG_PKG" ; then
- FUNCSTACK=no
- else
- FUNCSTACK=yes
- fi
-fi
case "X-$FUNCSTACK" in
- X-|X-yes)
- FUNCSTACK="yes"
+ X-yes)
+ FUNCSTACK=yes
AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_FUNCSTACK], [1],
[Define if the function stack tracing code is to be compiled in])
;;
*)
+ FUNCSTACK=no
AC_MSG_RESULT([no])
;;
esac