summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-04-30 19:23:26 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-04-30 19:23:26 (GMT)
commit5773fd34bc5adf59b4530d95ac9f0c0585902803 (patch)
tree456ad239799382e1f083fb7fc74399e43b471912 /configure.in
parent0138995d1ce2068db1f790503435a2121132d3ad (diff)
downloadhdf5-5773fd34bc5adf59b4530d95ac9f0c0585902803.zip
hdf5-5773fd34bc5adf59b4530d95ac9f0c0585902803.tar.gz
hdf5-5773fd34bc5adf59b4530d95ac9f0c0585902803.tar.bz2
[svn-r14902] Merged fortran_1_8 branch changes r14505:14901 into the trunk. New fortran wrappers added.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 10 insertions, 36 deletions
diff --git a/configure.in b/configure.in
index 8a45e38..c34e47a 100644
--- a/configure.in
+++ b/configure.in
@@ -26,7 +26,7 @@ dnl
dnl NOTE: Don't forget to change the version number here when we do a
dnl release!!!
dnl
-AC_INIT([HDF5], [1.9.5], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.8.0], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AM_CONFIG_HEADER([src/H5config.h])
@@ -1011,7 +1011,7 @@ AC_ARG_ENABLE(production,
[Determines how to run the compiler.])])
case "X-$enable_production" in
- X-yes)
+ X-|X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
@@ -1053,7 +1053,7 @@ case "X-$enable_production" in
H5_CXXFLAGS="$H5_CXXFLAGS $PROD_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $PROD_FCFLAGS"
;;
- X-|X-no)
+ X-no)
enable_production="no"
AC_MSG_RESULT([development])
CONFIG_MODE=development
@@ -1728,21 +1728,13 @@ AC_MSG_RESULT([no]))
dnl Check whether the global variable `timezone' is defined.
AC_MSG_CHECKING([for global timezone variable])
-
-case "`uname`" in
- CYGWIN*)
- AC_MSG_RESULT([disabled in CYGWIN])
- ;;
- *)
- AC_TRY_LINK([
- #include <sys/time.h>
- #include <time.h>], [timezone=0;],
- AC_DEFINE([HAVE_TIMEZONE], [1],
- [Define if `timezone' is a global variable])
- AC_MSG_RESULT([yes]),
- AC_MSG_RESULT([no]))
- ;;
-esac
+AC_TRY_LINK([
+#include <sys/time.h>
+#include <time.h>], [timezone=0;],
+AC_DEFINE([HAVE_TIMEZONE], [1],
+ [Define if `timezone' is a global variable])
+AC_MSG_RESULT([yes]),
+AC_MSG_RESULT([no]))
dnl Check whether `struct timezone' is defined.
AC_STRUCT_TIMEZONE
@@ -2814,24 +2806,6 @@ else
AC_MSG_RESULT([false])
fi
-dnl ----------------------------------------------------------------------
-dnl Set the flag to indicate that the machine has window style pathname,
-dnl that is, "drive-letter:\" (e.g. "C:") or "drive-letter:/" (e.g. "C:/").
-dnl (This flag should be _unset_ for all machines, except for Windows, where
-dnl it's set in the custom Windows H5pubconf.h file)
-dnl
-AC_MSG_CHECKING([if the machine has window style path name])
-AC_CACHE_VAL([hdf5_have_window_path], [hdf5_have_window_path=no])
-
-if test ${hdf5_have_window_path} = "yes"; then
- AC_DEFINE([HAVE_WINDOW_PATH], [1],
- [Define if your system has window style path name.])
- AC_MSG_RESULT([true])
-else
- AC_MSG_RESULT([false])
-fi
-
-
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from
dnl long double to integers accurately. This flag should be set "yes" for