summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-05 18:35:55 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-05 18:35:55 (GMT)
commit5bd2405c11837865b6d7c54e30933dbc0b43c938 (patch)
tree3846aa1cfe5990b95aaf591904c74582d0fec683 /configure.in
parente182fc3bb89b465640b6428c15abd57e1b3fd8e6 (diff)
downloadhdf5-5bd2405c11837865b6d7c54e30933dbc0b43c938.zip
hdf5-5bd2405c11837865b6d7c54e30933dbc0b43c938.tar.gz
hdf5-5bd2405c11837865b6d7c54e30933dbc0b43c938.tar.bz2
[svn-r14933] Purpose: Updating HDF5 to use automake 1.10.1 and libtool 2.2.2
Description: Applying update to autotools that was applied to 1.8 a couple of weeks ago to the trunk. Updated bin/reconfigure script to reflect the new versions of libtool and automake in the /home1/packages/ directory. Rearranged configure.in script. When using libtool 2.2.2, the libtool script doesn't generate until later in the configuration process, so I had to move a test that parsed through the libtool script to a point after where it was actually being generated. Ran libtoolize on the project, and ran bin/reconfigure to regenerate configure and Makefile.in's throughout. Tested: kagiso, smirom, linew (h5committest)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in59
1 files changed, 29 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index 8a45e38..7db15d3 100644
--- a/configure.in
+++ b/configure.in
@@ -3462,36 +3462,6 @@ else
BYTESEX="little-endian"
fi
-dnl Are we compiling static libraries, shared libraries, or both? This
-dnl is only used for the libhdf5.settings file. We can't just look at
-dnl $enable_static and $enable_shared because if they're yes the ltconfig
-dnl might have decided that one or the other is simply not possible.
-dnl Therefore we have to ask the generated `libtool' shell script
-dnl which 'features' it has enabled.
-AC_SUBST([STATIC_SHARED])
-if (./libtool --features | grep '^enable shared libraries' > /dev/null); then
- enable_shared=yes
-else
- enable_shared=no
-fi
-
-if (./libtool --features | grep '^enable static libraries' > /dev/null); then
- enable_static=yes
-else
- enable_static=no
-fi
-
-if test "X$enable_static" = "Xyes" && test "X$enable_shared" = "Xyes"; then
- STATIC_SHARED="static, shared"
-elif test "X$enable_static" = "Xyes"; then
- STATIC_SHARED="static"
-elif test "X$enable_shared" = "Xyes"; then
- STATIC_SHARED="shared"
-else
- STATIC_SHARED="none"
-fi
-
-
dnl Parallel support? (set above except empty if none)
PARALLEL=${PARALLEL:-no}
@@ -3827,6 +3797,35 @@ touch ./config/stamp2
# Finally the makefiles
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+dnl Are we compiling static libraries, shared libraries, or both? This
+dnl is only used for the libhdf5.settings file. We can't just look at
+dnl $enable_static and $enable_shared because if they're yes the ltconfig
+dnl might have decided that one or the other is simply not possible.
+dnl Therefore we have to ask the generated `libtool' shell script
+dnl which 'features' it has enabled.
+AC_SUBST([STATIC_SHARED])
+if (./libtool --features | grep '^enable shared libraries' > /dev/null); then
+ enable_shared=yes
+else
+ enable_shared=no
+fi
+
+if (./libtool --features | grep '^enable static libraries' > /dev/null); then
+ enable_static=yes
+else
+ enable_static=no
+fi
+
+if test "X$enable_static" = "Xyes" && test "X$enable_shared" = "Xyes"; then
+ STATIC_SHARED="static, shared"
+elif test "X$enable_static" = "Xyes"; then
+ STATIC_SHARED="static"
+elif test "X$enable_shared" = "Xyes"; then
+ STATIC_SHARED="shared"
+else
+ STATIC_SHARED="none"
+fi
+
chmod 755 tools/misc/h5cc
if test "X$HDF_FORTRAN" = "Xyes"; then