summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2007-06-14 14:18:46 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2007-06-14 14:18:46 (GMT)
commit9238d327a330f7e25404f580780b752f11bb0de8 (patch)
treec443f6105cc8133f83160c0f3c83f957fd3c558b /configure.in
parentd05df8434b2eb7f1282615f701dbf7cbf9f1ac6e (diff)
downloadhdf5-9238d327a330f7e25404f580780b752f11bb0de8.zip
hdf5-9238d327a330f7e25404f580780b752f11bb0de8.tar.gz
hdf5-9238d327a330f7e25404f580780b752f11bb0de8.tar.bz2
[svn-r13865] Purpose: Adding a new macro, H5_HAVE_OFFSETOF.
Description: When the compiler has the __offsetof__ extension, the H5_HAVE_OFFSETOF macro will be defined. When the compiler does not have the extension, the macro will remain undefined. Tested: kagiso
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b7caccd..71fd657 100644
--- a/configure.in
+++ b/configure.in
@@ -1932,6 +1932,13 @@ AC_TRY_COMPILE(,[(void)__FUNCTION__],
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))
+AC_MSG_CHECKING([for __offsetof__ extension])
+AC_TRY_COMPILE(,[size_t __offsetof__(unused)],
+ AC_DEFINE([HAVE_OFFSETOF], [1],
+ [Define if the __offsetof__ extension is present])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no]))
+
dnl ----------------------------------------------------------------------
dnl Try to figure out how to print `long long'. Some machines use `%lld'
dnl and others use `%qd'. There may be more! The final `l' is a