summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-09-06 16:57:05 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-09-06 16:57:05 (GMT)
commit9b1828ffd0799edabec86b79b15bd4b6b70bee28 (patch)
tree47c3dcb429728e47c3e55e520bb3ed7a0ead7051 /configure.in
parentf0bb265b2e4d8dfd9034950d4cbbb41e5233930d (diff)
downloadhdf5-9b1828ffd0799edabec86b79b15bd4b6b70bee28.zip
hdf5-9b1828ffd0799edabec86b79b15bd4b6b70bee28.tar.gz
hdf5-9b1828ffd0799edabec86b79b15bd4b6b70bee28.tar.bz2
[svn-r11353] Purpose:
Bug fix Description: Configure should now throw an error when C++ or threadsafe is enabled and a parallel compiler is being used. Platforms tested: sleipnir and modi4 Tested --enable-cxx --enable-parallel --disable-cxx --enable-cxx --disable-parallel cases in particular. Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 28ace27..cbc127a 100644
--- a/configure.in
+++ b/configure.in
@@ -2033,15 +2033,25 @@ AC_ARG_ENABLE([parallel],
dnl The --enable-parallel flag is not compatible with --enable-cxx.
dnl If the user tried to specify both flags, throw an error.
-if test "${enable_cxx}" = "yes" -a "$enable_parallel" = "yes"; then
+if test "X${HDF_CXX}" = "Xyes" -a "X${enable_parallel}" = "Xyes"; then
AC_MSG_ERROR([--enable-cxx and --enable-parallel flags are incompatible])
fi
dnl --enable-parallel is also incompatible with --enable-threadsafe.
-if test "${enable_threadsafe}" = "yes" -a "$enable_parallel" = "yes"; then
+if test "X${THREADSAFE}" = "Xyes" -a "X${enable_parallel}" = "Xyes"; then
AC_MSG_ERROR([--enable-threadsafe and --enable-parallel flags are incompatible])
fi
+dnl It's possible to build in parallel by specifying a parallel compiler
+dnl without using the --enable-parallel flag. This isn't allowed with
+dnl C++ or threadsafe, either.
+if test "X${PARALLEL}" != "X" -a "X${enable_cxx}" = "Xyes" ; then
+ AC_MSG_ERROR([An MPI compiler is being used; --enable-cxx is not allowed])
+fi
+if test "X${PARALLEL}" != "X" -a "X${THREADSAFE}" = "Xyes"; then
+ AC_MSG_ERROR([An MPI compiler is being used; --enable-threadsafe is not allowed])
+fi
+
AC_MSG_CHECKING([for parallel support files])
case "X-$enable_parallel" in
X-|X-no|X-none)