summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-10 20:38:42 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-10 20:38:42 (GMT)
commitb101eca9f1b7b28020d3b31c74efecfa34fb8324 (patch)
treef3adac7f081a9f803958b405a49fa08247a113be /configure.in
parentcbf1ec6eb44d6e0fd1ff90879884dfb556d3c5c0 (diff)
downloadhdf5-b101eca9f1b7b28020d3b31c74efecfa34fb8324.zip
hdf5-b101eca9f1b7b28020d3b31c74efecfa34fb8324.tar.gz
hdf5-b101eca9f1b7b28020d3b31c74efecfa34fb8324.tar.bz2
[svn-r11519] Purpose:
Bug fix Description: Some platforms complain that tcp.h is present but cannot be compiled. Solution: This is because tcp.h needs in.h to be included. Checked for netinet/in.h and included it when netinet/tcp.h is being checked. Platforms tested: mir, cu11
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 80c1a38..d4ee233 100644
--- a/configure.in
+++ b/configure.in
@@ -1449,7 +1449,9 @@ AC_ARG_ENABLE([stream-vfd],
if test "$STREAM_VFD" = "yes"; then
AC_MSG_RESULT([yes])
- AC_CHECK_HEADERS([netinet/tcp.h sys/filio.h])
+ AC_CHECK_HEADERS([netinet/in.h])
+ AC_CHECK_HEADERS([netinet/tcp.h], , , [#include <netinet/in.h>])
+ AC_CHECK_HEADERS([sys/filio.h])
AC_DEFINE([HAVE_STREAM], [1],
[Define if the stream virtual file driver should be compiled])