summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
commitbcf3f797d442096d4ec5fcbe009b20b84b1adc85 (patch)
treeb8148c7861e75841758a4a173c89979e8de8b06e /configure.in
parent1199296120cab95a4ef8de64538d8be3a44b9efe (diff)
downloadhdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.zip
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.gz
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.bz2
[svn-r11566] Purpose:
Makefile bug fix Description: Previously, automake didn't output rules to build perform/mpi-perf or the test/gen_* programs. Now these can be built by typing 'make mpi-perf' (or 'make foo') or by configuring with --enable-build-all. Solution: Automake doesn't like having rules for programs it doesn't build. Tricked it by having these programs built "sometimes"--whenever the user enables --build-all. This should be used mostly for testing and to ensure that these helper programs compile. ***IMPORTANT*** These programs do *not* currently compile. When --enable-build-all is used (not the default), gen_new_fill fails because it uses an old API. This is an existing "bug" that has simply been exposed by this checkin. Platforms tested: sleipnir, modi4, sol Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d4ee233..2205f93 100644
--- a/configure.in
+++ b/configure.in
@@ -3157,6 +3157,25 @@ else
fi
dnl ----------------------------------------------------------------------
+dnl Some programs shouldn't be built by default (e.g., programs to generate
+dnl data files used by tests, some optional tests).
+dnl Check if they want such programs built anyway.
+dnl
+AC_MSG_CHECKING([additional programs should be built])
+AC_ARG_ENABLE([build-all],
+ [AC_HELP_STRING([--enable-build-all],
+ [Build helper programs that only developers should need [default=no]])],
+ [BUILD_ALL=$enableval],
+ [BUILD_ALL=no])
+
+if test "X$BUILD_ALL" = "Xyes"; then
+ echo "yes"
+else
+ echo "no"
+fi
+AM_CONDITIONAL([BUILD_ALL_CONDITIONAL], [test "X$BUILD_ALL" = "Xyes"])
+
+dnl ----------------------------------------------------------------------
dnl Create automake conditionals to tell automake makefiles which directories
dnl need to be compiled