summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-09-06 04:11:33 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-09-06 04:11:33 (GMT)
commitf0bb265b2e4d8dfd9034950d4cbbb41e5233930d (patch)
treee542c261473cd411ad284c7cb823b87aff3dd782 /configure.in
parentc12eeffd9ffbb4547607800daea873508f2c1f00 (diff)
downloadhdf5-f0bb265b2e4d8dfd9034950d4cbbb41e5233930d.zip
hdf5-f0bb265b2e4d8dfd9034950d4cbbb41e5233930d.tar.gz
hdf5-f0bb265b2e4d8dfd9034950d4cbbb41e5233930d.tar.bz2
[svn-r11350] Purpose:
Bug fix. Description: The incompatibility of enable-parallel and enable-cxx was not correctly coded. It would complained even for the case of ./configure --enable-cxx --disable-parallel. Solution: Changed it to use "$enable_XYZ" = "yes". Fixed the same for the enable-threadsafe checking too. Platforms tested: tested in heping. Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d2de3a9..28ace27 100644
--- a/configure.in
+++ b/configure.in
@@ -2033,12 +2033,12 @@ AC_ARG_ENABLE([parallel],
dnl The --enable-parallel flag is not compatible with --enable-cxx.
dnl If the user tried to specify both flags, throw an error.
-if test "X${HDF_CXX}" != "X" && test "X$enable_parallel" != "X"; then
+if test "${enable_cxx}" = "yes" -a "$enable_parallel" = "yes"; then
AC_MSG_ERROR([--enable-cxx and --enable-parallel flags are incompatible])
fi
dnl --enable-parallel is also incompatible with --enable-threadsafe.
-if test "X${THREADSAFE}" != "X" && test "X$enable_parallel" != "X"; then
+if test "${enable_threadsafe}" = "yes" -a "$enable_parallel" = "yes"; then
AC_MSG_ERROR([--enable-threadsafe and --enable-parallel flags are incompatible])
fi