summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScott Wegner <swegner@hdfgroup.org>2008-02-19 13:32:19 (GMT)
committerScott Wegner <swegner@hdfgroup.org>2008-02-19 13:32:19 (GMT)
commitff9a968785e6684e53172c2fcad0cb5a9d2e2ab0 (patch)
treee8d3ed7921e812342d345f0ef89c1c5a9dabe93d /configure.in
parenta937d785c0a3fa0f9342aef69f37d0a91216c620 (diff)
downloadhdf5-ff9a968785e6684e53172c2fcad0cb5a9d2e2ab0.zip
hdf5-ff9a968785e6684e53172c2fcad0cb5a9d2e2ab0.tar.gz
hdf5-ff9a968785e6684e53172c2fcad0cb5a9d2e2ab0.tar.bz2
[svn-r14607] Purpose: Apply Cygwin patch to trunk
Description: This is the same patch that Mike McGreevy helped me with on the 1.8 branch. The latest cygwin DLL has trouble with the global timezone variable. Now in configure, we target CYGWIN with a case statement, and avoid the problem. Tested: Cygwin on WinXP
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 15 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index f8b7ce0..002be2b 100644
--- a/configure.in
+++ b/configure.in
@@ -1728,13 +1728,21 @@ AC_MSG_RESULT([no]))
dnl Check whether the global variable `timezone' is defined.
AC_MSG_CHECKING([for global timezone variable])
-AC_TRY_LINK([
-#include <sys/time.h>
-#include <time.h>], [timezone=0;],
-AC_DEFINE([HAVE_TIMEZONE], [1],
- [Define if `timezone' is a global variable])
-AC_MSG_RESULT([yes]),
-AC_MSG_RESULT([no]))
+
+case "'uname'" in
+ CYGWIN*)
+ AC_MSG_RESULT([disabled in CYGWIN])
+ ;;
+ *)
+ AC_TRY_LINK([
+ #include <sys/time.h>
+ #include <time.h>], [timezone=0;],
+ AC_DEFINE([HAVE_TIMEZONE], [1],
+ [Define if `timezone' is a global variable])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no]))
+ ;;
+esac
dnl Check whether `struct timezone' is defined.
AC_STRUCT_TIMEZONE