summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-08-12 22:04:35 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-08-12 22:04:35 (GMT)
commit328d540a34a6ccabd9a354453b38accef0dd6682 (patch)
tree3f2338d555f4b059fbfd34c49ce3d2d49321b150 /configure.in
parent7a1fcfa41974c02b1b7787e2f9627e0027868860 (diff)
downloadhdf5-328d540a34a6ccabd9a354453b38accef0dd6682.zip
hdf5-328d540a34a6ccabd9a354453b38accef0dd6682.tar.gz
hdf5-328d540a34a6ccabd9a354453b38accef0dd6682.tar.bz2
[svn-r17347] Description:
Bring r17299:17346 from trunk to revise_chunks branch (including rerunning bin/reconfigure, after the autotools update in the trunk) Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (smirom) w/Intel compilers w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, in production mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in production mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 2a6a265..7cc5e6d 100644
--- a/configure.in
+++ b/configure.in
@@ -26,7 +26,7 @@ dnl
dnl NOTE: Don't forget to change the version number here when we do a
dnl release!!!
dnl
-AC_INIT([HDF5], [1.9.44-FA_a3], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.9.45-FA_a3], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AM_CONFIG_HEADER([src/H5config.h])
@@ -2686,7 +2686,7 @@ dnl bug also occurs at SGI IRIX 6.5 C with compiler version lower than or equal
dnl In case people still use the old compiler, we keep this flag.
AC_MSG_CHECKING([if irregular hyperslab optimization code works inside MPI-IO])
-AC_CACHE_VAL([hdf5_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
if test ${hdf5_mpi_complex_derived_datatype_works} = "yes"; then
AC_DEFINE([MPI_COMPLEX_DERIVED_DATATYPE_WORKS], [1],
@@ -2705,7 +2705,7 @@ dnl and SGI altix. For those systems, we have to turn off this feature and use i
dnl
AC_MSG_CHECKING([if MPI-IO can do collective IO when one or more processes don't do IOs])
-AC_CACHE_VAL([hdf5_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
if test ${hdf5_mpi_special_collective_io_works} = "yes"; then
AC_DEFINE([MPI_SPECIAL_COLLECTIVE_IO_WORKS], [1],
@@ -2834,7 +2834,7 @@ AC_ARG_ENABLE([direct-vfd],
[DIRECT_VFD=$enableval], [DIRECT_VFD=yes])
if test "$DIRECT_VFD" = "yes"; then
- AC_CACHE_VAL([hdf5_direct_io],
+ AC_CACHE_VAL([hdf5_cv_direct_io],
[AC_TRY_RUN([
#include <sys/types.h>
#include <sys/stat.h>
@@ -2994,7 +2994,7 @@ AC_MSG_CHECKING([if converting from long double to integers works])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_integer_works=${hdf5_ldouble_to_integer_works=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_integer_works],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_integer_works],
[AC_TRY_RUN([
int main(void)
{
@@ -3144,7 +3144,7 @@ dnl than 0.5.
dnl
AC_MSG_CHECKING([if accurately roundup converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_accurate],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3181,7 +3181,7 @@ dnl during conversion.
dnl
AC_MSG_CHECKING([if right maximum converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_right_maximum],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_right_maximum],
[AC_TRY_RUN([
int main(void)
{
@@ -3226,7 +3226,7 @@ AC_MSG_CHECKING([if correctly converting long double to unsigned int values])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_uint_accurate=${hdf5_ldouble_to_uint_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_uint_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_uint_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3428,7 +3428,7 @@ AC_MSG_CHECKING([if correctly converting long double to (unsigned) long long val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_llong_accurate=${hdf5_ldouble_to_llong_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_llong_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_llong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3489,7 +3489,7 @@ AC_MSG_CHECKING([if correctly converting (unsigned) long long to long double val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_llong_to_ldouble_correct=${hdf5_llong_to_ldouble_correct=no}
else
- AC_CACHE_VAL([hdf5_llong_to_ldouble_correct],
+ AC_CACHE_VAL([hdf5_cv_llong_to_ldouble_correct],
[AC_TRY_RUN([
int main(void)
{