summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>2000-11-16 14:50:38 (GMT)
committerRobb Matzke <matzke@llnl.gov>2000-11-16 14:50:38 (GMT)
commit3081ac613aa8f0f0c30f8fe876c96e79fb2467b3 (patch)
tree95495ee1c093394327acf0f11f274373c60f9030 /configure.in
parentf5198a8a79452e5e410f82a6b4b5ecec1392f71e (diff)
downloadhdf5-3081ac613aa8f0f0c30f8fe876c96e79fb2467b3.zip
hdf5-3081ac613aa8f0f0c30f8fe876c96e79fb2467b3.tar.gz
hdf5-3081ac613aa8f0f0c30f8fe876c96e79fb2467b3.tar.bz2
[svn-r2944] ./hdf5/configure.in
* 2000-11-15 Robb Matzke <matzke@llnl.gov> (CC_VERSION) The compiler is always expanded to a full path name if possible. This feature enhancement was requested by Mark Miller, LLNL.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 14 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index d96702d..7c5ab9e 100644
--- a/configure.in
+++ b/configure.in
@@ -1398,23 +1398,22 @@ fi
dnl Parallel support? (set above except empty if none)
PARALLEL=${PARALLEL:-no}
-dnl Compiler with version information
+dnl Compiler with version information. This consists of the full path
+dnl name of the compiler and the reported version number.
AC_SUBST(CC_VERSION)
-if test -n "$cc_vendor" && test -n "$cc_version"; then
- CC_VERSION="$CC ($cc_vendor-$cc_version)"
+if `echo $CC | grep / 2>&1 /dev/null`; then
+ CC_VERSION="$CC"
else
- dnl If $CC contains directory component, take it as is;
- dnl else search it among PATH components.
- if `echo $CC | grep / 2>&1 /dev/null`; then
- CC_VERSION="$CC"
- else
- for x in `echo $PATH | sed -e 's/:/ /g'`; do
- if test -x $x/$CC; then
- CC_VERSION="$x/$CC"
- break
- fi
- done
- fi
+ CC_VERSION="$CC";
+ for x in `echo $PATH | sed -e 's/:/ /g'`; do
+ if test -x $x/$CC; then
+ CC_VERSION="$x/$CC"
+ break
+ fi
+ done
+fi
+if test -n "$cc_vendor" && test -n "$cc_version"; then
+ CC_VERSION="$CC_VERSION ($cc_vendor-$cc_version)"
fi
dnl ----------------------------------------------------------------------